summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 17ab46d859..1128aeab6d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -39,8 +39,8 @@ define Build/tplink-safeloader
endef
define Build/append-dtb
- $(if $(DEVICE_DTS_DIR),$(call Image/BuildDTB,$(DEVICE_DTS_DIR)/$(DEVICE_DTS).dts,$(DTS_DIR)/$(DEVICE_DTS).dtb))
- cat $(DTS_DIR)/$(DEVICE_DTS).dtb >> $@
+ $(call Image/BuildDTB,$(if $(DEVICE_DTS_DIR),$(DEVICE_DTS_DIR),$(DTS_DIR))/$(DEVICE_DTS).dts,$@.dtb)
+ cat $@.dtb >> $@
endef
define Build/fit