summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/package-defaults.mk1
-rw-r--r--rules.mk6
-rw-r--r--toolchain/gdb/Makefile1
-rw-r--r--toolchain/insight/Makefile1
4 files changed, 1 insertions, 8 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 62ccbb93ef..8f35c3293e 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -64,6 +64,7 @@ ifneq ($(strip $(PKG_UNPACK)),)
endif
EXTRA_CXXFLAGS = $(EXTRA_CFLAGS)
+DISABLE_NLS:=--disable-nls
CONFIGURE_PREFIX:=/usr
CONFIGURE_ARGS = \
diff --git a/rules.mk b/rules.mk
index 0769a09278..cc02b91bc9 100644
--- a/rules.mk
+++ b/rules.mk
@@ -260,12 +260,6 @@ else
$(SCRIPT_DIR)/rstrip.sh
endif
-ifeq ($(CONFIG_ENABLE_LOCALE),true)
- DISABLE_NLS:=--enable-nls
-else
- DISABLE_NLS:=--disable-nls
-endif
-
ifeq ($(CONFIG_IPV6),y)
DISABLE_IPV6:=
else
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 627baff528..10de1f883f 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -29,7 +29,6 @@ define Host/Configure
--host=$(GNU_HOST_NAME) \
--target=$(REAL_GNU_TARGET_NAME) \
--disable-werror \
- $(DISABLE_NLS) \
--without-uiout \
--disable-tui --disable-gdbtk --without-x \
--without-included-gettext \
diff --git a/toolchain/insight/Makefile b/toolchain/insight/Makefile
index 9fb39e1932..3744f56451 100644
--- a/toolchain/insight/Makefile
+++ b/toolchain/insight/Makefile
@@ -28,7 +28,6 @@ define Host/Configure
--build=$(GNU_HOST_NAME) \
--host=$(GNU_HOST_NAME) \
--target=$(REAL_GNU_TARGET_NAME) \
- $(DISABLE_NLS) \
--enable-threads \
--enable-werror=no \
);