summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/quilt.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index c569231173..d3233d8238 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -66,9 +66,10 @@ define Build/Patch/Default
$(call PatchDir,$(PATCH_DIR),)
endef
+kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
define Kernel/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
- $(CP) $(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.) $(LINUX_DIR)/
+ $(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
$(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
$(call PatchDir,$(PATCH_DIR),platform/)