summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds5
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh6
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.11
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt9
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-omy-x1.c106
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/generic/profiles/omy.mk16
-rw-r--r--target/linux/ar71xx/image/Makefile8
-rw-r--r--tools/firmware-utils/src/mktplinkfw.c6
13 files changed, 164 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index eff6e0d451..cfe5f1d739 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -394,6 +394,11 @@ om5p-an)
ucidef_set_led_netdev "port2" "port2" "om5p:blue:lan" "eth1"
;;
+omy-x1)
+ ucidef_set_led_default "power" "POWER" "omy:green:power" "1"
+ ucidef_set_led_default "wan" "WAN" "omy:green:wan" "eth0"
+ ;;
+
qihoo-c301)
ucidef_set_led_wlan "wlan2g" "WLAN2G" "qihoo:red:status" "phy1tpt"
;;
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index d083a799fa..a2251d1c15 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -214,6 +214,9 @@ get_status_led() {
om5p-an)
status_led="om5p:blue:power"
;;
+ omy-x1)
+ status_led="omy:green:power"
+ ;;
onion-omega)
status_led="onion:amber:system"
;;
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 46f1685647..199379e9fa 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -123,6 +123,9 @@ tplink_board_detect() {
"007260"*)
model="TellStick ZNet Lite"
;;
+ "066602"*)
+ model="OMYlink OMY-X1"
+ ;;
"3C0001"*)
model="OOLITE"
;;
@@ -632,6 +635,9 @@ ar71xx_board_detect() {
*"OM5P AN")
name="om5p-an"
;;
+ *"OMY-X1")
+ name="omy-x1"
+ ;;
*"Onion Omega")
name="onion-omega"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index d41081942a..1d3695f372 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -333,6 +333,7 @@ platform_check_image() {
gl-inet | \
mc-mac1200r | \
minibox-v1 |\
+ omy-x1 |\
onion-omega | \
oolite | \
smart-300 | \
diff --git a/target/linux/ar71xx/config-4.1 b/target/linux/ar71xx/config-4.1
index 0570749f8e..d740c2e8e8 100644
--- a/target/linux/ar71xx/config-4.1
+++ b/target/linux/ar71xx/config-4.1
@@ -108,6 +108,7 @@ CONFIG_ATH79_MACH_NBG460N=y
CONFIG_ATH79_MACH_NBG6716=y
CONFIG_ATH79_MACH_OM2P=y
CONFIG_ATH79_MACH_OM5P=y
+CONFIG_ATH79_MACH_OMY_X1=y
CONFIG_ATH79_MACH_ONION_OMEGA=y
CONFIG_ATH79_MACH_PB42=y
CONFIG_ATH79_MACH_PB44=y
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index c9ee1228d6..b11dd91d83 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -111,6 +111,7 @@ CONFIG_ATH79_MACH_NBG460N=y
CONFIG_ATH79_MACH_NBG6716=y
CONFIG_ATH79_MACH_OM2P=y
CONFIG_ATH79_MACH_OM5P=y
+CONFIG_ATH79_MACH_OMY_X1=y
CONFIG_ATH79_MACH_ONION_OMEGA=y
CONFIG_ATH79_MACH_PB42=y
CONFIG_ATH79_MACH_PB44=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 8256b0e238..92e453cd93 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -853,6 +853,15 @@ config ATH79_MACH_OM5P
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_OMY_X1
+ bool "OMYlink OMY X1 support"
+ select SOC_AR934X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_ONION_OMEGA
bool "ONION OMEGA support"
select SOC_AR933X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 0f8410a45f..021168cb33 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -114,6 +114,7 @@ obj-$(CONFIG_ATH79_MACH_MZK_W300NH) += mach-mzk-w300nh.o
obj-$(CONFIG_ATH79_MACH_NBG460N) += mach-nbg460n.o
obj-$(CONFIG_ATH79_MACH_OM2P) += mach-om2p.o
obj-$(CONFIG_ATH79_MACH_OM5P) += mach-om5p.o
+obj-$(CONFIG_ATH79_MACH_OMY_X1) += mach-omy-x1.o
obj-$(CONFIG_ATH79_MACH_ONION_OMEGA) += mach-onion-omega.o
obj-$(CONFIG_ATH79_MACH_PB42) += mach-pb42.o
obj-$(CONFIG_ATH79_MACH_PB44) += mach-pb44.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-omy-x1.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-omy-x1.c
new file mode 100644
index 0000000000..c99e3d7457
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-omy-x1.c
@@ -0,0 +1,106 @@
+/*
+ * OMYlink OMY-X1 board support
+ *
+ * Copyright (C) 2016 L. D. Pinney <ldpinney@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+
+
+#define OMY_X1_GPIO_LED_POWER 19
+#define OMY_X1_GPIO_LED_WAN 22
+
+#define OMY_X1_GPIO_BTN_RESET 17
+
+#define OMY_X1_KEYS_POLL_INTERVAL 20 /* msecs */
+#define OMY_X1_KEYS_DEBOUNCE_INTERVAL (3 * OMY_X1_KEYS_POLL_INTERVAL)
+
+static const char *omy_x1_part_probes[] = {
+ "tp-link",
+ NULL,
+};
+
+static struct flash_platform_data omy_x1_flash_data = {
+ .part_probes = omy_x1_part_probes,
+};
+
+static struct gpio_led omy_x1_leds_gpio[] __initdata = {
+ {
+ .name = "omy:green:wan",
+ .gpio = OMY_X1_GPIO_LED_WAN,
+ .active_low = 1,
+ }, {
+ .name = "omy:green:power",
+ .gpio = OMY_X1_GPIO_LED_POWER,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button omy_x1_gpio_keys[] __initdata = {
+ {
+ .desc = "Reset button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = OMY_X1_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = OMY_X1_GPIO_BTN_RESET,
+ .active_low = 1,
+ }
+};
+
+static void __init omy_x1_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+ u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+ ath79_gpio_function_setup(AR934X_GPIO_FUNC_JTAG_DISABLE,
+ AR934X_GPIO_FUNC_CLK_OBS4_EN);
+
+ ath79_register_m25p80(&omy_x1_flash_data);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(omy_x1_leds_gpio),
+ omy_x1_leds_gpio);
+
+ ath79_register_gpio_keys_polled(1, OMY_X1_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(omy_x1_gpio_keys),
+ omy_x1_gpio_keys);
+
+ ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_SW_PHY_SWAP);
+
+ ath79_register_mdio(1, 0x0);
+
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, -1);
+ ath79_init_mac(ath79_eth1_data.mac_addr, mac, 0);
+
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_switch_data.phy_poll_mask = BIT(0);
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(0);
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio1_device.dev;
+ ath79_register_eth(0);
+
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_register_eth(1);
+
+ ath79_register_wmac(ee, mac);
+
+}
+
+MIPS_MACHINE(ATH79_MACH_OMY_X1, "OMY-X1", "OMYlink OMY-X1",
+ omy_x1_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index e965f440c2..e63e71762b 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -114,6 +114,7 @@ enum ath79_mach_type {
ATH79_MACH_OM2P, /* OpenMesh OM2P */
ATH79_MACH_OM5P_AN, /* OpenMesh OM5P-AN */
ATH79_MACH_OM5P, /* OpenMesh OM5P */
+ ATH79_MACH_OMY_X1, /* OMYlink OMY-X1 */
ATH79_MACH_ONION_OMEGA, /* ONION OMEGA */
ATH79_MACH_PB42, /* Atheros PB42 */
ATH79_MACH_PB92, /* Atheros PB92 */
diff --git a/target/linux/ar71xx/generic/profiles/omy.mk b/target/linux/ar71xx/generic/profiles/omy.mk
new file mode 100644
index 0000000000..4055dfc2e9
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/omy.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/OMYX1
+ NAME:=OMYlink OMY-X1
+ PACKAGES:=
+endef
+
+define Profile/OMYX1/Description
+ Package set optimized for the OMYlink OMY-X1.
+endef
+$(eval $(call Profile,OMYX1))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 44b9178906..be978561c4 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -531,6 +531,14 @@ define Device/minibox-v1
endef
TARGET_DEVICES += minibox-v1
+define Device/omy-x1
+ $(Device/tplink-8mlzma)
+ BOARDNAME := OMY-X1
+ DEVICE_PROFILE := OMYX1
+ TPLINK_HWID := 0x06660201
+endef
+TARGET_DEVICES += omy-x1
+
define Device/onion-omega
$(Device/tplink-16mlzma)
BOARDNAME := ONION-OMEGA
diff --git a/tools/firmware-utils/src/mktplinkfw.c b/tools/firmware-utils/src/mktplinkfw.c
index 9fd5e3830a..692e48b8da 100644
--- a/tools/firmware-utils/src/mktplinkfw.c
+++ b/tools/firmware-utils/src/mktplinkfw.c
@@ -35,6 +35,7 @@
#define HWID_ANTMINER_S3 0x04440301
#define HWID_GL_INET_V1 0x08000001
#define HWID_GS_OOLITE_V1 0x3C000101
+#define HWID_OMY_X1 0x06660201
#define HWID_ONION_OMEGA 0x04700001
#define HWID_TL_MR10U_V1 0x00100101
#define HWID_TL_MR13U_V1 0x00130101
@@ -430,6 +431,11 @@ static struct board_info boards[] = {
.hw_rev = 1,
.layout_id = "16Mlzma",
}, {
+ .id = "OMY-X1",
+ .hw_id = HWID_OMY_X1,
+ .hw_rev = 1,
+ .layout_id = "8Mlzma",
+ }, {
.id = "ONION-OMEGA",
.hw_id = HWID_ONION_OMEGA,
.hw_rev = 1,