summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/quilt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index d3233d8238..c47a9262d9 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -126,7 +126,7 @@ define Build/Quilt
$(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
$(STAMP_CHECKED): $(STAMP_PATCHED)
- if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt next >/dev/null 2>&1 && quilt push -a || quilt top >/dev/null 2>&1); fi
+ if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); if quilt next >/dev/null 2>&1; then quilt push -a; else quilt top; fi >/dev/null 2>&1); fi
touch $$@
quilt-check: $(STAMP_PREPARED) FORCE