summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/download.mk20
-rw-r--r--include/prereq-build.mk12
2 files changed, 30 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 3866242805..3c7cb7e77b 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -46,7 +46,7 @@ endef
define DownloadMethod/svn
$(call wrap_mirror, \
- echo "Checking out files from svn repository..."; \
+ echo "Checking out files from the svn repository..."; \
mkdir -p $(TMP_DIR)/dl && \
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
@@ -59,8 +59,24 @@ define DownloadMethod/svn
)
endef
+define DownloadMethod/git
+ $(call wrap_mirror, \
+ echo "Checking out files from the git repository..."; \
+ mkdir -p $(TMP_DIR)/dl && \
+ cd $(TMP_DIR)/dl && \
+ rm -rf $(SUBDIR) && \
+ [ \! -d $(SUBDIR) ] && \
+ git-clone $(URL) $(SUBDIR) && \
+ (cd $(SUBDIR) && git-checkout $(VERSION)) && \
+ echo "Packing checkout..." && \
+ rm -rf $(SUBDIR)/.git && \
+ $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+ mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+ )
+endef
+
Validate/svn=VERSION SUBDIR
-#Validate/git=VERSION SUBDIR
+Validate/git=VERSION SUBDIR
define Download/Defaults
URL:=
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c31020c321..9b77a1baf7 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -119,6 +119,18 @@ $(eval $(call Require,gnutar, \
Please install GNU tar. \
))
+define Require/git
+ which git-clone
+endef
+
+$(eval $(call Require,git, \
+ Please install git. \
+))
+
+$(eval $(call RequireCommand,svn, \
+ Please install the subversion client. \
+))
+
$(eval $(call RequireCommand,autoconf, \
Please install GNU autoconf. \
))