summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/host.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/include/host.mk b/include/host.mk
index 00eb1f55aa..9d40ec40a3 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -39,12 +39,11 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
else \
echo 'FIND_L=find $$(1) -follow' >> $@; \
fi; \
+ if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
+ echo 'XARGS:=xargs -r' >> $@; \
+ else \
+ echo 'XARGS:=xargs' >> $@; \
+ fi; \
)
endif
-
-ifeq ($(HOST_OS),Linux)
- XARGS:=xargs -r
-else
- XARGS:=xargs
-endif