summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/generic/patches-3.14/025-bcma_backport.patch6
-rw-r--r--target/linux/generic/patches-3.14/132-mips_inline_dma_ops.patch4
-rw-r--r--target/linux/generic/patches-3.14/204-module_strip.patch4
-rw-r--r--target/linux/generic/patches-3.14/230-openwrt_lzma_options.patch2
-rw-r--r--target/linux/generic/patches-3.14/306-mips_mem_functions_performance.patch2
-rw-r--r--target/linux/generic/patches-3.14/408-mtd-old-rootfs-squashfs-splitter.patch2
-rw-r--r--target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch2
-rw-r--r--target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch2
-rw-r--r--target/linux/generic/patches-3.14/502-yaffs-3.10-disable-proc-entry.patch2
-rw-r--r--target/linux/generic/patches-3.14/531-debloat_lzma.patch39
-rw-r--r--target/linux/generic/patches-3.14/600-netfilter_layer7_2.22.patch2
-rw-r--r--target/linux/generic/patches-3.14/604-netfilter_conntrack_flush.patch2
-rw-r--r--target/linux/generic/patches-3.14/610-netfilter_match_bypass_default_checks.patch8
-rw-r--r--target/linux/generic/patches-3.14/615-netfilter_add_xt_id_match.patch2
-rw-r--r--target/linux/generic/patches-3.14/643-bridge_remove_ipv6_dependency.patch2
-rw-r--r--target/linux/generic/patches-3.14/645-bridge_multicast_to_unicast.patch12
-rw-r--r--target/linux/generic/patches-3.14/653-disable_netlink_trim.patch2
-rw-r--r--target/linux/generic/patches-3.14/657-qdisc_reduce_truesize.patch2
-rw-r--r--target/linux/generic/patches-3.14/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch2
-rw-r--r--target/linux/generic/patches-3.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch2
-rw-r--r--target/linux/generic/patches-3.14/750-hostap_txpower.patch2
-rw-r--r--target/linux/generic/patches-3.14/773-bgmac-add-srab-switch.patch2
-rw-r--r--target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch2
-rw-r--r--target/linux/generic/patches-3.14/902-debloat_proc.patch2
-rw-r--r--target/linux/generic/patches-3.14/941-ocf_20120127.patch2
25 files changed, 57 insertions, 54 deletions
diff --git a/target/linux/generic/patches-3.14/025-bcma_backport.patch b/target/linux/generic/patches-3.14/025-bcma_backport.patch
index 436c1cf363..2791ce1bb6 100644
--- a/target/linux/generic/patches-3.14/025-bcma_backport.patch
+++ b/target/linux/generic/patches-3.14/025-bcma_backport.patch
@@ -106,7 +106,7 @@
pci_write_config_byte(dev, PCI_INTERRUPT_LINE, dev->irq);
readrq = pcie_get_readrq(dev);
-@@ -617,6 +617,6 @@ int bcma_core_pci_pcibios_map_irq(const
+@@ -617,6 +617,6 @@ int bcma_core_pci_pcibios_map_irq(const
pc_host = container_of(dev->bus->ops, struct bcma_drv_pci_host,
pci_ops);
@@ -983,7 +983,7 @@
+#endif /* LINUX_BCMA_DRIVER_PCIE2_H_ */
--- a/drivers/bcma/scan.c
+++ b/drivers/bcma/scan.c
-@@ -32,17 +32,17 @@ static const struct bcma_device_id_name
+@@ -32,17 +32,17 @@ static const struct bcma_device_id_name
{ BCMA_CORE_4706_CHIPCOMMON, "BCM4706 ChipCommon" },
{ BCMA_CORE_4706_SOC_RAM, "BCM4706 SOC RAM" },
{ BCMA_CORE_4706_MAC_GBIT, "BCM4706 GBit MAC" },
@@ -1290,7 +1290,7 @@
static void bcma_core_mips_set_irq(struct bcma_device *dev, unsigned int irq)
{
unsigned int oldirq = bcma_core_mips_irq(dev);
-@@ -229,11 +230,51 @@ u32 bcma_cpu_clock(struct bcma_drv_mips
+@@ -229,11 +230,51 @@ u32 bcma_cpu_clock(struct bcma_drv_mips
}
EXPORT_SYMBOL(bcma_cpu_clock);
diff --git a/target/linux/generic/patches-3.14/132-mips_inline_dma_ops.patch b/target/linux/generic/patches-3.14/132-mips_inline_dma_ops.patch
index 366dbc5b97..e43de025e6 100644
--- a/target/linux/generic/patches-3.14/132-mips_inline_dma_ops.patch
+++ b/target/linux/generic/patches-3.14/132-mips_inline_dma_ops.patch
@@ -510,7 +510,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
void dma_free_noncoherent(struct device *dev, size_t size, void *vaddr,
-@@ -159,8 +137,8 @@ void dma_free_noncoherent(struct device
+@@ -159,8 +137,8 @@ void dma_free_noncoherent(struct device
}
EXPORT_SYMBOL(dma_free_noncoherent);
@@ -650,7 +650,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
void dma_cache_sync(struct device *dev, void *vaddr, size_t size,
enum dma_data_direction direction)
-@@ -347,23 +225,10 @@ void dma_cache_sync(struct device *dev,
+@@ -347,23 +225,10 @@ void dma_cache_sync(struct device *dev,
EXPORT_SYMBOL(dma_cache_sync);
diff --git a/target/linux/generic/patches-3.14/204-module_strip.patch b/target/linux/generic/patches-3.14/204-module_strip.patch
index d6aa3592e0..dcb4aee1f3 100644
--- a/target/linux/generic/patches-3.14/204-module_strip.patch
+++ b/target/linux/generic/patches-3.14/204-module_strip.patch
@@ -78,7 +78,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#ifdef MODULE
#define __MODULE_INFO(tag, name, info) \
static const char __UNIQUE_ID(name)[] \
-@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
+@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
= __stringify(tag) "=" info
#else /* !MODULE */
/* This struct is here for syntactic coherency, it is not used */
@@ -88,7 +88,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#endif
#define __MODULE_PARM_TYPE(name, _type) \
__MODULE_INFO(parmtype, name##type, #name ":" _type)
-@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
+@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
/* One for each parameter, describing how to use it. Some files do
multiple of these per line, so can't just use MODULE_INFO. */
#define MODULE_PARM_DESC(_parm, desc) \
diff --git a/target/linux/generic/patches-3.14/230-openwrt_lzma_options.patch b/target/linux/generic/patches-3.14/230-openwrt_lzma_options.patch
index c32a23129c..1e6ad39228 100644
--- a/target/linux/generic/patches-3.14/230-openwrt_lzma_options.patch
+++ b/target/linux/generic/patches-3.14/230-openwrt_lzma_options.patch
@@ -1,6 +1,6 @@
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
-@@ -304,7 +304,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+@@ -304,7 +304,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \
diff --git a/target/linux/generic/patches-3.14/306-mips_mem_functions_performance.patch b/target/linux/generic/patches-3.14/306-mips_mem_functions_performance.patch
index e6056fa5c4..9818677425 100644
--- a/target/linux/generic/patches-3.14/306-mips_mem_functions_performance.patch
+++ b/target/linux/generic/patches-3.14/306-mips_mem_functions_performance.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/include/asm/string.h
+++ b/arch/mips/include/asm/string.h
-@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
+@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
#define __HAVE_ARCH_MEMSET
extern void *memset(void *__s, int __c, size_t __count);
diff --git a/target/linux/generic/patches-3.14/408-mtd-old-rootfs-squashfs-splitter.patch b/target/linux/generic/patches-3.14/408-mtd-old-rootfs-squashfs-splitter.patch
index 0e91d40990..ff2c702a56 100644
--- a/target/linux/generic/patches-3.14/408-mtd-old-rootfs-squashfs-splitter.patch
+++ b/target/linux/generic/patches-3.14/408-mtd-old-rootfs-squashfs-splitter.patch
@@ -14,7 +14,7 @@
default y
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -668,6 +668,47 @@ mtd_pad_erasesize(struct mtd_info *mtd,
+@@ -668,6 +668,47 @@ mtd_pad_erasesize(struct mtd_info *mtd,
return len;
}
diff --git a/target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch b/target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
index 46881fca2c..4c4720341e 100644
--- a/target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
+++ b/target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
@@ -17,7 +17,7 @@
u64 offset, uint32_t mask_flags)
{
part->name = name;
-@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct
+@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct
part->mask_flags = mask_flags;
}
diff --git a/target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch b/target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch
index 4f2f4e6586..eec90fa413 100644
--- a/target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch
+++ b/target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch
@@ -30,7 +30,7 @@
/****************************************************************************/
enum read_type {
-@@ -1192,7 +1198,7 @@ static int m25p_probe(struct spi_device
+@@ -1192,7 +1198,7 @@ static int m25p_probe(struct spi_device
flash->mtd._write = m25p80_write;
/* prefer "small sector" erase if possible */
diff --git a/target/linux/generic/patches-3.14/502-yaffs-3.10-disable-proc-entry.patch b/target/linux/generic/patches-3.14/502-yaffs-3.10-disable-proc-entry.patch
index 5345678c56..5b73d3898b 100644
--- a/target/linux/generic/patches-3.14/502-yaffs-3.10-disable-proc-entry.patch
+++ b/target/linux/generic/patches-3.14/502-yaffs-3.10-disable-proc-entry.patch
@@ -8,7 +8,7 @@
static struct proc_dir_entry *my_proc_entry;
static char *yaffs_dump_dev_part0(char *buf, struct yaffs_dev *dev)
-@@ -3398,6 +3399,7 @@ static int yaffs_proc_write(struct file
+@@ -3398,6 +3399,7 @@ static int yaffs_proc_write(struct file
return yaffs_proc_debug_write(file, buf, count, data);
return yaffs_proc_write_trace_options(file, buf, count, data);
}
diff --git a/target/linux/generic/patches-3.14/531-debloat_lzma.patch b/target/linux/generic/patches-3.14/531-debloat_lzma.patch
index 9f9690f187..aa3c498016 100644
--- a/target/linux/generic/patches-3.14/531-debloat_lzma.patch
+++ b/target/linux/generic/patches-3.14/531-debloat_lzma.patch
@@ -124,7 +124,7 @@
/* LzmaDecode
--- a/lib/lzma/LzmaDec.c
+++ b/lib/lzma/LzmaDec.c
-@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
+@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
p->needFlush = 0;
}
@@ -219,26 +219,26 @@
{
UInt32 dicSize;
Byte d;
-@@ -935,33 +883,11 @@ static SRes LzmaDec_AllocateProbs2(CLzma
+@@ -935,7 +883,7 @@ static SRes LzmaDec_AllocateProbs2(CLzma
return SZ_OK;
}
-SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
--{
-- CLzmaProps propNew;
-- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
-- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
-- p->prop = propNew;
-- return SZ_OK;
--}
--
--SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
+static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
{
CLzmaProps propNew;
-- SizeT dicBufSize;
RINOK(LzmaProps_Decode(&propNew, props, propsSize));
- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
+@@ -943,28 +891,6 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
+ p->prop = propNew;
+ return SZ_OK;
+ }
+-
+-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
+-{
+- CLzmaProps propNew;
+- SizeT dicBufSize;
+- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
+- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
- dicBufSize = propNew.dicSize;
- if (p->dic == 0 || dicBufSize != p->dicBufSize)
- {
@@ -251,9 +251,12 @@
- }
- }
- p->dicBufSize = dicBufSize;
- p->prop = propNew;
- return SZ_OK;
- }
+- p->prop = propNew;
+- return SZ_OK;
+-}
+
+ SRes LzmaDecode(Byte *dest, SizeT *destLen, const Byte *src, SizeT *srcLen,
+ const Byte *propData, unsigned propSize, ELzmaFinishMode finishMode,
--- a/include/linux/lzma/LzmaEnc.h
+++ b/include/linux/lzma/LzmaEnc.h
@@ -31,9 +31,6 @@ typedef struct _CLzmaEncProps
@@ -597,7 +600,7 @@
void MatchFinder_Construct(CMatchFinder *p);
/* Conditions:
-@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
+@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
ISzAlloc *alloc);
void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
@@ -686,7 +689,7 @@
{
memmove(p->bufferBase,
p->buffer - p->keepSizeBefore,
-@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
+@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
p->buffer = p->bufferBase + p->keepSizeBefore;
}
diff --git a/target/linux/generic/patches-3.14/600-netfilter_layer7_2.22.patch b/target/linux/generic/patches-3.14/600-netfilter_layer7_2.22.patch
index 6d3db38eb4..39087200de 100644
--- a/target/linux/generic/patches-3.14/600-netfilter_layer7_2.22.patch
+++ b/target/linux/generic/patches-3.14/600-netfilter_layer7_2.22.patch
@@ -30,7 +30,7 @@
depends on NETFILTER_ADVANCED
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -161,6 +161,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
+@@ -161,6 +161,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
diff --git a/target/linux/generic/patches-3.14/604-netfilter_conntrack_flush.patch b/target/linux/generic/patches-3.14/604-netfilter_conntrack_flush.patch
index 88adb01955..83cd04ac8b 100644
--- a/target/linux/generic/patches-3.14/604-netfilter_conntrack_flush.patch
+++ b/target/linux/generic/patches-3.14/604-netfilter_conntrack_flush.patch
@@ -8,7 +8,7 @@
#include <net/net_namespace.h>
#ifdef CONFIG_SYSCTL
#include <linux/sysctl.h>
-@@ -268,10 +269,66 @@ static int ct_open(struct inode *inode,
+@@ -268,10 +269,66 @@ static int ct_open(struct inode *inode,
sizeof(struct ct_iter_state));
}
diff --git a/target/linux/generic/patches-3.14/610-netfilter_match_bypass_default_checks.patch b/target/linux/generic/patches-3.14/610-netfilter_match_bypass_default_checks.patch
index f652dafd18..358d64b1a1 100644
--- a/target/linux/generic/patches-3.14/610-netfilter_match_bypass_default_checks.patch
+++ b/target/linux/generic/patches-3.14/610-netfilter_match_bypass_default_checks.patch
@@ -76,10 +76,11 @@
counters = alloc_counters(table);
if (IS_ERR(counters))
-@@ -966,6 +995,14 @@ copy_entries_to_user(unsigned int total_
+@@ -965,6 +994,14 @@ copy_entries_to_user(unsigned int total_
+ ret = -EFAULT;
goto free_counters;
}
-
++
+ flags = e->ip.flags & IPT_F_MASK;
+ if (copy_to_user(userptr + off
+ + offsetof(struct ipt_entry, ip.flags),
@@ -87,7 +88,6 @@
+ ret = -EFAULT;
+ goto free_counters;
+ }
-+
+
for (i = sizeof(struct ipt_entry);
i < e->target_offset;
- i += m->u.match_size) {
diff --git a/target/linux/generic/patches-3.14/615-netfilter_add_xt_id_match.patch b/target/linux/generic/patches-3.14/615-netfilter_add_xt_id_match.patch
index 07b4bfae6a..5d16b2a83f 100644
--- a/target/linux/generic/patches-3.14/615-netfilter_add_xt_id_match.patch
+++ b/target/linux/generic/patches-3.14/615-netfilter_add_xt_id_match.patch
@@ -37,7 +37,7 @@
depends on NETFILTER_ADVANCED
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -139,6 +139,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_ESP) +=
+@@ -139,6 +139,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_ESP) +=
obj-$(CONFIG_NETFILTER_XT_MATCH_HASHLIMIT) += xt_hashlimit.o
obj-$(CONFIG_NETFILTER_XT_MATCH_HELPER) += xt_helper.o
obj-$(CONFIG_NETFILTER_XT_MATCH_HL) += xt_hl.o
diff --git a/target/linux/generic/patches-3.14/643-bridge_remove_ipv6_dependency.patch b/target/linux/generic/patches-3.14/643-bridge_remove_ipv6_dependency.patch
index e5f4eff5b6..e6721defbd 100644
--- a/target/linux/generic/patches-3.14/643-bridge_remove_ipv6_dependency.patch
+++ b/target/linux/generic/patches-3.14/643-bridge_remove_ipv6_dependency.patch
@@ -25,7 +25,7 @@
Ethernet bridge, which means that the different Ethernet segments it
--- a/net/ipv6/Makefile
+++ b/net/ipv6/Makefile
-@@ -45,3 +45,4 @@ obj-y += addrconf_core.o exthdrs_core.o
+@@ -45,3 +45,4 @@ obj-y += addrconf_core.o exthdrs_core.o
obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
diff --git a/target/linux/generic/patches-3.14/645-bridge_multicast_to_unicast.patch b/target/linux/generic/patches-3.14/645-bridge_multicast_to_unicast.patch
index 4e63e9ad57..27cfe4e14c 100644
--- a/target/linux/generic/patches-3.14/645-bridge_multicast_to_unicast.patch
+++ b/target/linux/generic/patches-3.14/645-bridge_multicast_to_unicast.patch
@@ -197,7 +197,7 @@
}
#endif
-@@ -1465,6 +1492,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1465,6 +1492,7 @@ static int br_multicast_ipv4_rcv(struct
struct sk_buff *skb,
u16 vid)
{
@@ -205,7 +205,7 @@
struct sk_buff *skb2 = skb;
const struct iphdr *iph;
struct igmphdr *ih;
-@@ -1538,7 +1566,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1538,7 +1566,7 @@ static int br_multicast_ipv4_rcv(struct
case IGMP_HOST_MEMBERSHIP_REPORT:
case IGMPV2_HOST_MEMBERSHIP_REPORT:
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@@ -214,7 +214,7 @@
break;
case IGMPV3_HOST_MEMBERSHIP_REPORT:
err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
-@@ -1547,7 +1575,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1547,7 +1575,7 @@ static int br_multicast_ipv4_rcv(struct
err = br_ip4_multicast_query(br, port, skb2, vid);
break;
case IGMP_HOST_LEAVE_MESSAGE:
@@ -223,7 +223,7 @@
break;
}
-@@ -1565,6 +1593,7 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1565,6 +1593,7 @@ static int br_multicast_ipv6_rcv(struct
struct sk_buff *skb,
u16 vid)
{
@@ -231,7 +231,7 @@
struct sk_buff *skb2;
const struct ipv6hdr *ip6h;
u8 icmp6_type;
-@@ -1674,7 +1703,8 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1674,7 +1703,8 @@ static int br_multicast_ipv6_rcv(struct
}
mld = (struct mld_msg *)skb_transport_header(skb2);
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@@ -241,7 +241,7 @@
break;
}
case ICMPV6_MLD2_REPORT:
-@@ -1691,7 +1721,7 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1691,7 +1721,7 @@ static int br_multicast_ipv6_rcv(struct
goto out;
}
mld = (struct mld_msg *)skb_transport_header(skb2);
diff --git a/target/linux/generic/patches-3.14/653-disable_netlink_trim.patch b/target/linux/generic/patches-3.14/653-disable_netlink_trim.patch
index ffde041f8a..7ce7c65892 100644
--- a/target/linux/generic/patches-3.14/653-disable_netlink_trim.patch
+++ b/target/linux/generic/patches-3.14/653-disable_netlink_trim.patch
@@ -1,6 +1,6 @@
--- a/net/netlink/af_netlink.c
+++ b/net/netlink/af_netlink.c
-@@ -1740,27 +1740,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -1740,27 +1740,7 @@ void netlink_detachskb(struct sock *sk,
static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
{
diff --git a/target/linux/generic/patches-3.14/657-qdisc_reduce_truesize.patch b/target/linux/generic/patches-3.14/657-qdisc_reduce_truesize.patch
index e27d0a04d6..93ff7ba71d 100644
--- a/target/linux/generic/patches-3.14/657-qdisc_reduce_truesize.patch
+++ b/target/linux/generic/patches-3.14/657-qdisc_reduce_truesize.patch
@@ -24,7 +24,7 @@ commont qdiscs.
}
--- a/net/sched/sch_fifo.c
+++ b/net/sched/sch_fifo.c
-@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
+@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
static int pfifo_enqueue(struct sk_buff *skb, struct Qdisc *sch)
{
diff --git a/target/linux/generic/patches-3.14/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch b/target/linux/generic/patches-3.14/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
index ab8d9688fd..c7126dad25 100644
--- a/target/linux/generic/patches-3.14/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
+++ b/target/linux/generic/patches-3.14/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
@@ -308,7 +308,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
err = ip6_tnl_xmit2(skb, dev, dsfield, &fl6, encap_limit, &mtu);
if (err != 0) {
/* XXX: send ICMP error even if DF is not set. */
-@@ -1257,6 +1407,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
+@@ -1257,6 +1407,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
t->parms.flowinfo = p->flowinfo;
t->parms.link = p->link;
t->parms.proto = p->proto;
diff --git a/target/linux/generic/patches-3.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch b/target/linux/generic/patches-3.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
index 3c45090f4e..6daebe251b 100644
--- a/target/linux/generic/patches-3.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
+++ b/target/linux/generic/patches-3.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
@@ -55,7 +55,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
--- a/net/ipv4/fib_semantics.c
+++ b/net/ipv4/fib_semantics.c
-@@ -138,6 +138,10 @@ const struct fib_prop fib_props[RTN_MAX
+@@ -138,6 +138,10 @@ const struct fib_prop fib_props[RTN_MAX
.error = -EINVAL,
.scope = RT_SCOPE_NOWHERE,
},
diff --git a/target/linux/generic/patches-3.14/750-hostap_txpower.patch b/target/linux/generic/patches-3.14/750-hostap_txpower.patch
index fc032a93c9..768c80f73b 100644
--- a/target/linux/generic/patches-3.14/750-hostap_txpower.patch
+++ b/target/linux/generic/patches-3.14/750-hostap_txpower.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/hostap/hostap_ap.c
+++ b/drivers/net/wireless/hostap/hostap_ap.c
-@@ -2403,13 +2403,13 @@ int prism2_ap_get_sta_qual(local_info_t
+@@ -2403,13 +2403,13 @@ int prism2_ap_get_sta_qual(local_info_t
addr[count].sa_family = ARPHRD_ETHER;
memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
if (sta->last_rx_silence == 0)
diff --git a/target/linux/generic/patches-3.14/773-bgmac-add-srab-switch.patch b/target/linux/generic/patches-3.14/773-bgmac-add-srab-switch.patch
index c2eef69924..fe52ccc33e 100644
--- a/target/linux/generic/patches-3.14/773-bgmac-add-srab-switch.patch
+++ b/target/linux/generic/patches-3.14/773-bgmac-add-srab-switch.patch
@@ -12,7 +12,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
#include <bcm47xx_nvram.h>
static const struct bcma_device_id bgmac_bcma_tbl[] = {
-@@ -1405,6 +1406,17 @@ static void bgmac_mii_unregister(struct
+@@ -1405,6 +1406,17 @@ static void bgmac_mii_unregister(struct
mdiobus_free(mii_bus);
}
diff --git a/target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch b/target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch
index e483ddd63b..0ecc7053f9 100644
--- a/target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch
+++ b/target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch
@@ -15,7 +15,7 @@
default y
--- a/drivers/pci/quirks.c
+++ b/drivers/pci/quirks.c
-@@ -41,6 +41,7 @@ static void quirk_mmio_always_on(struct
+@@ -41,6 +41,7 @@ static void quirk_mmio_always_on(struct
DECLARE_PCI_FIXUP_CLASS_EARLY(PCI_ANY_ID, PCI_ANY_ID,
PCI_CLASS_BRIDGE_HOST, 8, quirk_mmio_always_on);
diff --git a/target/linux/generic/patches-3.14/902-debloat_proc.patch b/target/linux/generic/patches-3.14/902-debloat_proc.patch
index d9284be0ae..53614da884 100644
--- a/target/linux/generic/patches-3.14/902-debloat_proc.patch
+++ b/target/linux/generic/patches-3.14/902-debloat_proc.patch
@@ -199,7 +199,7 @@
&fib_triestat_fops))
goto out2;
-@@ -2594,17 +2596,21 @@ int __net_init fib_proc_init(struct net
+@@ -2594,17 +2596,21 @@ int __net_init fib_proc_init(struct net
return 0;
out3:
diff --git a/target/linux/generic/patches-3.14/941-ocf_20120127.patch b/target/linux/generic/patches-3.14/941-ocf_20120127.patch
index d97f7746ea..b8b1eed9bd 100644
--- a/target/linux/generic/patches-3.14/941-ocf_20120127.patch
+++ b/target/linux/generic/patches-3.14/941-ocf_20120127.patch
@@ -24,7 +24,7 @@
* All of these routines try to estimate how many bits of randomness a
* particular randomness source. They do this by keeping track of the
* first and second order deltas of the event timings.
-@@ -889,6 +899,63 @@ void add_disk_randomness(struct gendisk
+@@ -889,6 +899,63 @@ void add_disk_randomness(struct gendisk
}
#endif