summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/adm5120/Makefile2
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.8/617-MIPS-ath79-add-Netgear-WNR2000v3-support.patch4
-rw-r--r--target/linux/at91/Makefile2
-rw-r--r--target/linux/atheros/Makefile2
-rw-r--r--target/linux/avr32/Makefile2
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/cns21xx/Makefile2
-rw-r--r--target/linux/cns3xxx/Makefile2
-rw-r--r--target/linux/ep93xx/Makefile2
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch6
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/mpc52xx/Makefile2
-rw-r--r--target/linux/mpc83xx/Makefile2
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/mvebu/Makefile2
-rw-r--r--target/linux/ppc40x/Makefile2
-rw-r--r--target/linux/ppc44x/Makefile2
-rw-r--r--target/linux/ramips/Makefile2
-rw-r--r--target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch6
-rw-r--r--target/linux/rb532/Makefile2
-rw-r--r--target/linux/realview/Makefile2
-rw-r--r--target/linux/uml/Makefile2
-rw-r--r--target/linux/x86/alix2/target.mk2
-rw-r--r--target/linux/x86/generic/target.mk2
-rw-r--r--target/linux/xburst/Makefile2
28 files changed, 34 insertions, 34 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 9bcbd0b554..b9a6776ae7 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -11,8 +11,8 @@ endif
ifeq ($(LINUX_VERSION),3.7.10)
LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
endif
-ifeq ($(LINUX_VERSION),3.8.9)
- LINUX_KERNEL_MD5SUM:=b5286ad3d8a729e9ae48b26211e05aec
+ifeq ($(LINUX_VERSION),3.8.10)
+ LINUX_KERNEL_MD5SUM:=3d5fb6d9add9cce7725bbe9b139c8d6e
endif
# disable the md5sum check for unknown kernel versions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index ac337195e2..3b50ba0375 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
SUBTARGETS:=router_le router_be rb1xx
INITRAMFS_EXTRA_FILES:=
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 7e24715371..baaccdaa82 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-3.8/617-MIPS-ath79-add-Netgear-WNR2000v3-support.patch b/target/linux/ar71xx/patches-3.8/617-MIPS-ath79-add-Netgear-WNR2000v3-support.patch
index 0b9c1efa9d..aa3edf0bd4 100644
--- a/target/linux/ar71xx/patches-3.8/617-MIPS-ath79-add-Netgear-WNR2000v3-support.patch
+++ b/target/linux/ar71xx/patches-3.8/617-MIPS-ath79-add-Netgear-WNR2000v3-support.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -119,6 +119,7 @@ enum ath79_mach_type {
+@@ -120,6 +120,7 @@ enum ath79_mach_type {
ATH79_MACH_WNDR3700, /* NETGEAR WNDR3700/WNDR3800/WNDRMAC */
ATH79_MACH_WNDR4300, /* NETGEAR WNDR4300 */
ATH79_MACH_WNR2000, /* NETGEAR WNR2000 */
@@ -28,7 +28,7 @@
select SOC_AR724X
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -100,6 +100,7 @@ obj-$(CONFIG_ATH79_MACH_WLAE_AG300N) +=
+@@ -101,6 +101,7 @@ obj-$(CONFIG_ATH79_MACH_WLAE_AG300N) +=
obj-$(CONFIG_ATH79_MACH_WNDR3700) += mach-wndr3700.o
obj-$(CONFIG_ATH79_MACH_WNDR4300) += mach-wndr4300.o
obj-$(CONFIG_ATH79_MACH_WNR2000) += mach-wnr2000.o
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index ea72b67e1b..38e2b03243 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
FEATURES:=squashfs jffs2 targz ext2 usb
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
index 4caff66d83..f0c1345dca 100644
--- a/target/linux/atheros/Makefile
+++ b/target/linux/atheros/Makefile
@@ -11,7 +11,7 @@ BOARD:=atheros
BOARDNAME:=Atheros AR231x/AR5312
FEATURES:=squashfs jffs2
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index b4d2b04ed0..38948ce6aa 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 52e4524f92..09410b5cef 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/cns21xx/Makefile b/target/linux/cns21xx/Makefile
index a5a90ff222..a33c61da85 100644
--- a/target/linux/cns21xx/Makefile
+++ b/target/linux/cns21xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/cns3xxx/Makefile b/target/linux/cns3xxx/Makefile
index 87f6c440d1..15422237f0 100644
--- a/target/linux/cns3xxx/Makefile
+++ b/target/linux/cns3xxx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ep93xx/Makefile b/target/linux/ep93xx/Makefile
index 72577204e7..0b36548a96 100644
--- a/target/linux/ep93xx/Makefile
+++ b/target/linux/ep93xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
DEVICE_TYPE:=developerboard
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 88f12b12c2..bcd0ff79fa 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs jffs2
SUBTARGETS=xway ase falcon
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
diff --git a/target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch b/target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch
index ee5fa73467..16da438183 100644
--- a/target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch
+++ b/target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch
@@ -25,7 +25,7 @@ Subject: [PATCH 19/25] owrt mtd split
---help---
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -844,6 +844,168 @@ static int refresh_rootfs_split(struct m
+@@ -833,6 +833,168 @@ static int refresh_rootfs_split(struct m
}
#endif /* CONFIG_MTD_ROOTFS_SPLIT */
@@ -194,7 +194,7 @@ Subject: [PATCH 19/25] owrt mtd split
/*
* This function, given a master MTD object and a partition table, creates
* and registers slave MTD objects which are bound to the master according to
-@@ -860,7 +1022,7 @@ int add_mtd_partitions(struct mtd_info *
+@@ -849,7 +1011,7 @@ int add_mtd_partitions(struct mtd_info *
struct mtd_part *slave;
uint64_t cur_offset = 0;
int i;
@@ -203,7 +203,7 @@ Subject: [PATCH 19/25] owrt mtd split
int ret;
#endif
-@@ -877,6 +1039,15 @@ int add_mtd_partitions(struct mtd_info *
+@@ -866,6 +1028,15 @@ int add_mtd_partitions(struct mtd_info *
add_mtd_device(&slave->mtd);
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index 8db4e90306..5e4d2c132d 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
DEVICE_TYPE:=developerboard
diff --git a/target/linux/mpc52xx/Makefile b/target/linux/mpc52xx/Makefile
index 7493441c56..94fe5f7925 100644
--- a/target/linux/mpc52xx/Makefile
+++ b/target/linux/mpc52xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
FEATURES:=targz ext4
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/mpc83xx/Makefile b/target/linux/mpc83xx/Makefile
index bb6f6986ee..7b5a7ac5d4 100644
--- a/target/linux/mpc83xx/Makefile
+++ b/target/linux/mpc83xx/Makefile
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
FEATURES:=squashfs targz
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 88d9b9543e..3129d188f0 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic p1020
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index fcb604af95..b6f917f401 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index ab79d7ce23..adc01938b7 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index 0a5533c601..fceccdf093 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index 1b359ad06b..f4a4212765 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
FEATURES:=squashfs gpio
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
diff --git a/target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch b/target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch
index 8f6899c4cc..f15d16f6da 100644
--- a/target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch
+++ b/target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch
@@ -25,7 +25,7 @@ Subject: [PATCH 19/25] owrt mtd split
---help---
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -844,6 +844,99 @@ static int refresh_rootfs_split(struct m
+@@ -833,6 +833,99 @@ static int refresh_rootfs_split(struct m
}
#endif /* CONFIG_MTD_ROOTFS_SPLIT */
@@ -125,7 +125,7 @@ Subject: [PATCH 19/25] owrt mtd split
/*
* This function, given a master MTD object and a partition table, creates
* and registers slave MTD objects which are bound to the master according to
-@@ -860,7 +953,7 @@ int add_mtd_partitions(struct mtd_info *
+@@ -849,7 +942,7 @@ int add_mtd_partitions(struct mtd_info *
struct mtd_part *slave;
uint64_t cur_offset = 0;
int i;
@@ -134,7 +134,7 @@ Subject: [PATCH 19/25] owrt mtd split
int ret;
#endif
-@@ -877,6 +970,14 @@ int add_mtd_partitions(struct mtd_info *
+@@ -866,6 +959,14 @@ int add_mtd_partitions(struct mtd_info *
add_mtd_device(&slave->mtd);
diff --git a/target/linux/rb532/Makefile b/target/linux/rb532/Makefile
index 56b2d20e53..52441810e5 100644
--- a/target/linux/rb532/Makefile
+++ b/target/linux/rb532/Makefile
@@ -11,7 +11,7 @@ BOARD:=rb532
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci targz broken
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index cc6d977677..ce5571f07e 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
DEVICE_TYPE:=developerboard
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index 3be431a62f..c906654424 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
FEATURES:=ext4 audio
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index 534ffa3463..ff4c29d6ef 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
kmod-ledtrig-netdev \
kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
CS5535_MASK:=0x0b000042
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
diff --git a/target/linux/x86/generic/target.mk b/target/linux/x86/generic/target.mk
index 4e5f373b1c..765d708509 100644
--- a/target/linux/x86/generic/target.mk
+++ b/target/linux/x86/generic/target.mk
@@ -1,6 +1,6 @@
BOARDNAME:=Generic
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
define Target/Description
Build firmware images for x86 based boards
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index 074f0545ed..f90c8ecf60 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
FEATURES:=jffs2 targz ubifs audio broken
SUBTARGETS:=qi_lb60 n516 n526 id800wt
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
DEVICE_TYPE=other