summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/cmake.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index 4c4af502cc..64a0654f96 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -4,6 +4,8 @@ ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
MAKE_FLAGS+=VERBOSE=1
endif
+CMAKE_SOURCE_DIR:=.
+
ifeq ($(CONFIG_CCACHE),)
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
CMAKE_C_COMPILER:=$(TOOLCHAIN_DIR)/bin/$(TARGET_CC)
@@ -53,8 +55,9 @@ define Build/Configure/Default
-DCMAKE_STRIP=: \
-DCMAKE_INSTALL_PREFIX=/usr \
-DDL_LIBRARY=$(STAGING_DIR) \
+ -DCMAKE_PREFIX_PATH=$(STAGING_DIR) \
$(CMAKE_OPTIONS) \
- . \
+ $(CMAKE_SOURCE_DIR) \
)
endef