summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/generic/patches-3.2/350-arm_compressed_size.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.2/350-arm_compressed_size.patch b/target/linux/generic/patches-3.2/350-arm_compressed_size.patch
new file mode 100644
index 0000000000..05d6618e91
--- /dev/null
+++ b/target/linux/generic/patches-3.2/350-arm_compressed_size.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/boot/compressed/Makefile
++++ b/arch/arm/boot/compressed/Makefile
+@@ -127,7 +127,7 @@ ccflags-y := -fpic -fno-builtin -I$(obj)
+ asflags-y := -Wa,-march=all
+
+ # Supply kernel BSS size to the decompressor via a linker symbol.
+-KBSS_SZ = $(shell size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
++KBSS_SZ = $(shell $(CROSS_COMPILE)size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
+ LDFLAGS_vmlinux = --defsym _kernel_bss_size=$(KBSS_SZ)
+ # Supply ZRELADDR to the decompressor via a linker symbol.
+ ifneq ($(CONFIG_AUTO_ZRELADDR),y)