summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--rules.mk3
-rw-r--r--target/linux/at91-2.6/base-files/default/etc/inittab3
-rw-r--r--target/linux/at91-2.6/image/Config.in5
-rw-r--r--target/linux/at91-2.6/image/Makefile15
-rw-r--r--tools/firmware-utils/src/trx.c1
5 files changed, 17 insertions, 10 deletions
diff --git a/rules.mk b/rules.mk
index 0ce75f55c0..1419f2f6a0 100644
--- a/rules.mk
+++ b/rules.mk
@@ -84,7 +84,8 @@ TARGET_CONFIGURE_OPTS:= \
RANLIB=$(TARGET_CROSS)ranlib \
STRIP=$(TARGET_CROSS)strip \
OBJCOPY=$(TARGET_CROSS)objcopy \
- OBJDUMP=$(TARGET_CROSS)objdump
+ OBJDUMP=$(TARGET_CROSS)objdump \
+ SIZE=$(TARGET_CROSS)size
# strip an entire directory
RSTRIP:= \
diff --git a/target/linux/at91-2.6/base-files/default/etc/inittab b/target/linux/at91-2.6/base-files/default/etc/inittab
index c1b9cd7eb9..a627ce5ffa 100644
--- a/target/linux/at91-2.6/base-files/default/etc/inittab
+++ b/target/linux/at91-2.6/base-files/default/etc/inittab
@@ -1,4 +1,5 @@
-::sysinit:/etc/init.d/rcS
+::sysinit:/etc/init.d/rcS S boot
+::shutdown:/etc/init.d/rcS K stop
tts/0::askfirst:/bin/ash --login
ttyS0::askfirst:/bin/ash --login
diff --git a/target/linux/at91-2.6/image/Config.in b/target/linux/at91-2.6/image/Config.in
index 4335faac5a..086f10d83e 100644
--- a/target/linux/at91-2.6/image/Config.in
+++ b/target/linux/at91-2.6/image/Config.in
@@ -3,6 +3,11 @@ config AT91_ROMBOOT
depends LINUX_2_6_AT91
default y
+config AT91_DFBOOT
+ bool "Build dataflashboot loader"
+ depends LINUX_2_6_AT91
+ default y
+
config AT91_UBOOT
bool "Build u-boot loader"
depends LINUX_2_6_AT91
diff --git a/target/linux/at91-2.6/image/Makefile b/target/linux/at91-2.6/image/Makefile
index 73a281b808..b498059a57 100644
--- a/target/linux/at91-2.6/image/Makefile
+++ b/target/linux/at91-2.6/image/Makefile
@@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Build/Clean
- $(MAKE) -C romboot clean
+# $(MAKE) -C romboot clean
+ $(MAKE) -C dfboot clean
$(MAKE) -C u-boot clean
endef
define Build/Compile
- $(MAKE) -C romboot compile
-# $(MAKE) -C u-boot configure
+# $(MAKE) -C romboot compile
+ $(MAKE) -C dfboot compile
$(MAKE) -C u-boot compile
$(KDIR)/u-boot-1.1.4/tools/ubparams
cp params $(KDIR)
@@ -23,8 +24,8 @@ endef
define Image/Prepare
cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
- cp $(KDIR)/romboot/romboot.bin $(KDIR)/romboot.bin
- cp $(KDIR)/romboot/rbptest.bin $(KDIR)/rbptest.bin
+ cp $(KDIR)/dfboot/dfboot.bin $(KDIR)/dfboot.bin
+ cp $(KDIR)/dfboot/dfbptest.bin $(KDIR)/dfbptest.bin
cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
dd if=$(KDIR)/u-boot.bin of=$(KDIR)/u-boot.block bs=100k count=1 conv=sync
cat $(KDIR)/u-boot.block $(KDIR)/params > $(KDIR)/u-boot.full
@@ -38,8 +39,8 @@ define Image/Build
dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=8448 conv=sync
dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=8448 conv=sync
cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
- $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/romboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
- cp $(KDIR)/rbptest.bin $(BIN_DIR)
+ $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
+ cp $(KDIR)/dfbptest.bin $(BIN_DIR)
$(call Image/Build/$(1),$(1))
endef
diff --git a/tools/firmware-utils/src/trx.c b/tools/firmware-utils/src/trx.c
index f2ad991367..1ad3de54f6 100644
--- a/tools/firmware-utils/src/trx.c
+++ b/tools/firmware-utils/src/trx.c
@@ -231,7 +231,6 @@ int main(int argc, char **argv)
fclose(out);
- printf("Offsets:\n0x%08x\n0x%08x\n0x%08x\n", p->offsets[0], p->offsets[1], p->offsets[2]);
return EXIT_SUCCESS;
}