summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 6cc10d95c3..823ddf93f8 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -45,7 +45,7 @@ define DownloadMethod/default
endef
define wrap_mirror
- $(if $(MIRROR),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
+ $(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
endef
define DownloadMethod/cvs