summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/input.mk2
-rw-r--r--package/kernel/linux/modules/other.mk1
-rw-r--r--target/linux/generic/config-4.01
3 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 6c9f228497..b44136b78c 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -11,7 +11,7 @@ define KernelPackage/hid
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=HID Devices
DEPENDS:=+kmod-input-core +kmod-input-evdev
- KCONFIG:=CONFIG_HID CONFIG_HIDRAW=y
+ KCONFIG:=CONFIG_HID CONFIG_HIDRAW=y CONFIG_HID_BATTERY_STRENGTH=y
FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
AUTOLOAD:=$(call AutoLoad,61,hid)
endef
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 18edaeffc5..6a5825011c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -746,6 +746,7 @@ define KernelPackage/zram
CONFIG_ZRAM \
CONFIG_ZRAM_DEBUG=n \
CONFIG_PGTABLE_MAPPING=n \
+ CONFIG_ZSMALLOC_STAT=n \
CONFIG_ZRAM_LZ4_COMPRESS=y
FILES:= \
$(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko@lt3.14 \
diff --git a/target/linux/generic/config-4.0 b/target/linux/generic/config-4.0
index 3e8bdad7bc..5e12b3b3f7 100644
--- a/target/linux/generic/config-4.0
+++ b/target/linux/generic/config-4.0
@@ -3694,6 +3694,7 @@ CONFIG_SND_PCM_OSS_PLUGINS=y
# CONFIG_SND_RME32 is not set
# CONFIG_SND_RME96 is not set
# CONFIG_SND_RME9652 is not set
+# CONFIG_SND_SE6X is not set
# CONFIG_SND_RTCTIMER is not set
# CONFIG_SND_SB16 is not set
# CONFIG_SND_SB8 is not set