summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-build.mk4
-rw-r--r--include/kernel.mk1
-rw-r--r--target/linux/aruba-2.6/image/Makefile4
-rw-r--r--target/linux/au1000-2.6/image/Makefile6
-rw-r--r--target/linux/brcm63xx-2.6/image/Makefile4
-rw-r--r--target/linux/rb532-2.6/image/Makefile4
6 files changed, 12 insertions, 11 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 55e1b82ebd..03b4769f4b 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -63,7 +63,7 @@ endif
define Kernel/Prepare/Default
bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
- [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
+ [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches
[ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
endef
define Kernel/Prepare
@@ -110,7 +110,7 @@ ifeq ($(KERNEL),2.6)
echo 'CONFIG_INITRAMFS_ROOT_UID=0' >> $(LINUX_DIR)/.config
echo 'CONFIG_INITRAMFS_ROOT_GID=0' >> $(LINUX_DIR)/.config
mkdir -p $(BUILD_DIR)/root/etc/init.d
- $(CP) $(TOPDIR)/target/linux/generic-2.6/files/init $(BUILD_DIR)/root/
+ $(CP) $(GENERIC_PLATFORM_DIR)/files/init $(BUILD_DIR)/root/
endef
else
define Kernel/SetInitramfs
diff --git a/include/kernel.mk b/include/kernel.mk
index b5950c3f5d..1f34f00ca4 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -27,6 +27,7 @@ else
endif
PLATFORM_DIR := $(TOPDIR)/target/linux/$(BOARD)-$(KERNEL)
+ GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
KERNEL_BUILD_DIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
LINUX_DIR := $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
diff --git a/target/linux/aruba-2.6/image/Makefile b/target/linux/aruba-2.6/image/Makefile
index 37dd6fccb0..e486b30ef2 100644
--- a/target/linux/aruba-2.6/image/Makefile
+++ b/target/linux/aruba-2.6/image/Makefile
@@ -18,12 +18,12 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE)
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
endef
define Image/BuildKernel
diff --git a/target/linux/au1000-2.6/image/Makefile b/target/linux/au1000-2.6/image/Makefile
index c9ab7caca9..b5ba3d4542 100644
--- a/target/linux/au1000-2.6/image/Makefile
+++ b/target/linux/au1000-2.6/image/Makefile
@@ -21,7 +21,7 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE)
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
DROP_SECTIONS := .reginfo .mdebug .comment .note .pdr .options .MIPS.options
@@ -32,13 +32,13 @@ define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
# Build RAM image
- $(MAKE) -C ../../generic-2.6/image/lzma-loader \
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
$(LOADER_MAKEOPTS) \
clean compile
$(OBJCOPY_SREC) $(KDIR)/loader.elf $(KDIR)/kernel.ram.srec
# Build Flash image
- $(MAKE) -C ../../generic-2.6/image/lzma-loader \
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
$(LOADER_MAKEOPTS) \
IMAGE_COPY=1 \
LOADER_ENTRY=$(FLASH_KERNEL) \
diff --git a/target/linux/brcm63xx-2.6/image/Makefile b/target/linux/brcm63xx-2.6/image/Makefile
index 27c7b49c39..5c16f0541c 100644
--- a/target/linux/brcm63xx-2.6/image/Makefile
+++ b/target/linux/brcm63xx-2.6/image/Makefile
@@ -18,12 +18,12 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE)
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) compile
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) compile
endef
define Image/Build
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 1f3a88ba40..4e1c1addd1 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -25,7 +25,7 @@ define Build/Compile
endef
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
define Image/Prepare
@@ -35,7 +35,7 @@ endef
define Image/BuildKernel
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
$(CP) $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
endef