summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/ipv6/thc-ipv6/Makefile15
-rw-r--r--package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch14
2 files changed, 14 insertions, 15 deletions
diff --git a/package/network/ipv6/thc-ipv6/Makefile b/package/network/ipv6/thc-ipv6/Makefile
index 4c75f1869b..fdfc1f2f01 100644
--- a/package/network/ipv6/thc-ipv6/Makefile
+++ b/package/network/ipv6/thc-ipv6/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=thc-ipv6
-PKG_VERSION:=2.0
+PKG_VERSION:=2.7
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://freeworld.thc.org/releases/
-PKG_MD5SUM:=5c9be9ad38ac15c368bb5140d031c051
+PKG_MD5SUM:=2975dd54be35b68c140eb2a6b8ef5e59
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
@@ -27,10 +27,11 @@ THC_APPLETS := \
fake_dnsupdate6 fake_mipv6 fake_mld26 fake_mld6 fake_mldrouter6 \
fake_router26 fake_router6 fake_solicitate6 flood_advertise6 \
flood_dhcpc6 flood_mld26 flood_mld6 flood_mldrouter6 flood_router26 \
- flood_router6 flood_solicitate6 fragmentation6 fuzz_ip6 \
- implementation6 implementation6d inverse_lookup6 kill_router6 \
- ndpexhaust6 node_query6 parasite6 passive_discovery6 randicmp6 \
- redir6 rsmurf6 sendpees6 sendpeesmp6 smurf6 thcping6 toobig6 trace6
+ flood_router6 flood_solicitate6 fragmentation6 fuzz_ip6 fuzz_dhcpc6 \
+ fuzz_dhcps6 implementation6 implementation6d inverse_lookup6 \
+ kill_router6 ndpexhaust6 node_query6 parasite6 passive_discovery6 \
+ randicmp6 redir6 rsmurf6 sendpees6 sendpeesmp6 smurf6 thcping6 \
+ toobig6 trace6
THC_DEPENDS_dnsdict6 := +libpthread
THC_DEPENDS_thcping6 := +librt
diff --git a/package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch b/package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch
index 5f87bcd350..1ef1f66be8 100644
--- a/package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch
+++ b/package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch
@@ -1,11 +1,9 @@
--- a/Makefile
+++ b/Makefile
-@@ -1,7 +1,7 @@
- CC=gcc
- #CFLAGS?=-Wall -ggdb
- CFLAGS?=-O2
--LDFLAGS+=-lpcap -lssl -lcrypto
-+LDFLAGS+=-lpcap
- PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_router26 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 thcping6 covert_send6 covert_send6d
- LIBS=thc-ipv6-lib.o
+@@ -1,5 +1,5 @@
+ # Comment out if openssl-dev is not present
+-HAVE_SSL=yes
++#HAVE_SSL=yes
+ CC=gcc
+ #CFLAGS=-g