summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/subdir.mk2
-rw-r--r--toolchain/Makefile2
-rw-r--r--tools/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index d079be118e..a097db2b1d 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -59,7 +59,7 @@ define stampfile
$(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
@+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
- $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
+ $(MAKE) $(if $(QUIET),--no-print-directory) $$($(1)/flags-$(3)) $(1)/$(3)
@mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
@touch $$($(1)/stamp-$(3))
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 141f478522..5585b76dba 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -57,7 +57,7 @@ ifndef DUMP_TARGET_DB
ifneq ($(ARCH),)
$(TOOLCHAIN_DIR)/info.mk: .config
@for dir in $(TOOLCHAIN_DIR); do ( \
- set -x; \
+ $(if $(QUIET),,set -x;) \
mkdir -p "$$dir"; \
cd "$$dir"; \
mkdir -p stamp lib usr/include usr/lib ; \
diff --git a/tools/Makefile b/tools/Makefile
index c3596b7591..80c2d11628 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -65,7 +65,7 @@ $(curdir)/builddirs-default := $(tools-y)
ifndef DUMP_TARGET_DB
define PrepareStaging
@for dir in $(1); do ( \
- set -x; \
+ $(if $(QUIET),,set -x;) \
mkdir -p "$$dir"; \
cd "$$dir"; \
mkdir -p bin lib include stamp; \