summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/.target.mk.swpbin0 -> 16384 bytes
-rw-r--r--include/kernel-build.mk1
-rw-r--r--include/target.mk2
3 files changed, 2 insertions, 1 deletions
diff --git a/include/.target.mk.swp b/include/.target.mk.swp
new file mode 100644
index 0000000000..d41d2ccd4a
--- /dev/null
+++ b/include/.target.mk.swp
Binary files differ
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 75c2bcf01a..b6d2cf5efb 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -77,6 +77,7 @@ define BuildKernel
$(MAKE) -C image compile TARGET_BUILD=
oldconfig menuconfig: $(STAMP_PREPARED) FORCE
+ [ -e "$(LINUX_CONFIG)" ] || touch "$(LINUX_CONFIG)"
$(LINUX_CONFCMD) > $(LINUX_DIR)/.config
touch $(LINUX_CONFIG)
$(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
diff --git a/include/target.mk b/include/target.mk
index be9f128cda..8b123959d3 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -109,7 +109,7 @@ GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLAT
GENERIC_FILES_DIR := $(GENERIC_PLATFORM_DIR)/files$(shell [ -d "$(GENERIC_PLATFORM_DIR)/files-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
-LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)))
+LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)) $(PLATFORM_DIR)/config-$(KERNEL_PATCHVER))
LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default))
ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))
LINUX_SUBCONFIG:=