summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--toolchain/gcc/final/Makefile4
-rw-r--r--toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch11
2 files changed, 15 insertions, 0 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 3fb5ccf83f..1212d145ab 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -16,6 +16,10 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
--with-libelf=$(TOPDIR)/staging_dir/host
endif
+ifdef CONFIG_USE_MUSL
+ GCC_MAKE += gcc_cv_libc_provides_ssp=yes
+endif
+
ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
GCC_CONFIGURE += \
--enable-sjlj-exceptions
diff --git a/toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch b/toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch
new file mode 100644
index 0000000000..1208e73029
--- /dev/null
+++ b/toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch
@@ -0,0 +1,11 @@
+--- gcc-4.7.4.org/gcc/gcc.c
++++ gcc-4.7.4/gcc/gcc.c
+@@ -603,7 +603,7 @@
+
+ #ifndef LINK_SSP_SPEC
+ #ifdef TARGET_LIBC_PROVIDES_SSP
+-#define LINK_SSP_SPEC "%{fstack-protector:}"
++#define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all:-lssp_nonshared}"
+ #else
+ #define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all:-lssp_nonshared -lssp}"
+ #endif