summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile2
-rw-r--r--target/linux/ixp4xx-2.6/image/apex/patches/100-slugos-nslu2-armeb_config.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index 17c0ab0d43..7d23002853 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -41,7 +41,7 @@ define Image/Build/slug
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
-k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
- -r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+ -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
endef
diff --git a/target/linux/ixp4xx-2.6/image/apex/patches/100-slugos-nslu2-armeb_config.patch b/target/linux/ixp4xx-2.6/image/apex/patches/100-slugos-nslu2-armeb_config.patch
index 9b1a9363d2..c05812dfe0 100644
--- a/target/linux/ixp4xx-2.6/image/apex/patches/100-slugos-nslu2-armeb_config.patch
+++ b/target/linux/ixp4xx-2.6/image/apex/patches/100-slugos-nslu2-armeb_config.patch
@@ -127,7 +127,7 @@ Index: apex-1.4.7/src/mach-ixp42x/slugos-nslu2-armeb_config
+CONFIG_ENV_REGION_KERNEL="fis://kernel"
+# CONFIG_ENV_REGION_KERNEL_SWAP is not set
+CONFIG_ENV_DEFAULT_CMDLINE_OVERRIDE=y
-+CONFIG_ENV_DEFAULT_CMDLINE="root=/dev/mtdblock4 rootfstype=squashfs,jffs2 console=ttyS0,115200"
++CONFIG_ENV_DEFAULT_CMDLINE="root=/dev/mtdblock4 rootfstype=squashfs,jffs2 console=ttyS0,115200 init=/etc/preinit noinitrd"
+# CONFIG_ENV_DEFAULT_STARTUP_OVERRIDE is not set
+CONFIG_USES_NOR_BOOTFLASH=y
+CONFIG_BIGENDIAN=y