summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/modules/network.mk12
-rw-r--r--target/linux/x86-2.6/config2
2 files changed, 13 insertions, 1 deletions
diff --git a/package/kernel/modules/network.mk b/package/kernel/modules/network.mk
index d75a65bf6d..000d5206c3 100644
--- a/package/kernel/modules/network.mk
+++ b/package/kernel/modules/network.mk
@@ -306,6 +306,18 @@ define KernelPackage/r8169
endef
$(eval $(call KernelPackage,r8169))
+define KernelPackage/ne2k-pci
+ TITLE:=ne2k-pci Ethernet Adapter kernel support
+ DESCRIPTION:=\
+ ne2k-pci Ethernet Adapter kernel support.
+ FILES:=$(MODULES_DIR)/kernel/drivers/net/ne2k-pci.$(LINUX_KMOD_SUFFIX)
+ KCONFIG:=$(CONFIG_NE2K-PCI)
+ DEPENDS:=@LINUX_2_6_X86
+ SUBMENU:=$(NDMENU)
+ AUTOLOAD:=$(call AutoLoad,50,ne2k-pci)
+endef
+$(eval $(call KernelPackage,ne2k-pci))
+
define KernelPackage/ixp4xx-npe
TITLE:=Intel(R) IXP4xx ethernet support
DESCRIPTION:=\
diff --git a/target/linux/x86-2.6/config b/target/linux/x86-2.6/config
index 81100c593b..3b5c0f2ecb 100644
--- a/target/linux/x86-2.6/config
+++ b/target/linux/x86-2.6/config
@@ -1035,7 +1035,7 @@ CONFIG_FORCEDETH=m
CONFIG_E100=m
# CONFIG_FEALNX is not set
CONFIG_NATSEMI=m
-# CONFIG_NE2K_PCI is not set
+CONFIG_NE2K_PCI=m
# CONFIG_8139CP is not set
CONFIG_8139TOO=m
CONFIG_8139TOO_PIO=y