summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/quilt/Makefile6
-rw-r--r--tools/quilt/patches/000-relocatable.patch17
-rw-r--r--tools/quilt/patches/001-fix_compile.patch2
3 files changed, 5 insertions, 20 deletions
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index c2dbc07c79..939ba69163 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=quilt
-PKG_VERSION:=0.63
+PKG_VERSION:=0.64
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/quilt
-PKG_MD5SUM:=c0ef4beb58a6fa72563b955e70624b6e
+PKG_MD5SUM:=fc0310db5868a0873d602d4332a76d43
include $(INCLUDE_DIR)/host-build.mk
diff --git a/tools/quilt/patches/000-relocatable.patch b/tools/quilt/patches/000-relocatable.patch
index aedb914c29..ed4f00adae 100644
--- a/tools/quilt/patches/000-relocatable.patch
+++ b/tools/quilt/patches/000-relocatable.patch
@@ -45,21 +45,6 @@
textdomain("quilt");
sub _($) {
---- a/quilt/scripts/inspect.in
-+++ b/quilt/scripts/inspect.in
-@@ -6,7 +6,11 @@
- #
- # See the COPYING and AUTHORS files for more details.
-
--: ${QUILT_DIR=@QUILT_DIR@}
-+if test -n "$STAGING_DIR"; then
-+ : ${QUILT_DIR="$STAGING_DIR/../host/share/quilt"}
-+else
-+ : ${QUILT_DIR=@QUILT_DIR@}
-+fi
-
- if ! [ -r $QUILT_DIR/scripts/patchfns ]
- then
--- a/quilt/scripts/patchfns.in
+++ b/quilt/scripts/patchfns.in
@@ -8,7 +8,11 @@
@@ -116,7 +101,7 @@
MKTEMP := @MKTEMP@
MSGMERGE := @MSGMERGE@
MSGFMT := @MSGFMT@
-@@ -49,8 +49,8 @@ USE_NLS := @USE_NLS@
+@@ -48,8 +48,8 @@ USE_NLS := @USE_NLS@
STAT_HARDLINK := @STAT_HARDLINK@
PATCH_WRAPPER := @PATCH_WRAPPER@
diff --git a/tools/quilt/patches/001-fix_compile.patch b/tools/quilt/patches/001-fix_compile.patch
index c829515f83..3ce93f0cf8 100644
--- a/tools/quilt/patches/001-fix_compile.patch
+++ b/tools/quilt/patches/001-fix_compile.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -272,13 +272,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
+@@ -271,13 +271,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
@$(if $(filter $@,$(NON_EXEC_IN)),,chmod +x $@)
configure : configure.ac aclocal.m4