summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--scripts/config/lxdialog/Makefile9
-rw-r--r--scripts/config/lxdialog/check-lxdialog.sh2
2 files changed, 9 insertions, 2 deletions
diff --git a/scripts/config/lxdialog/Makefile b/scripts/config/lxdialog/Makefile
index a82b2bac99..aed08e0170 100644
--- a/scripts/config/lxdialog/Makefile
+++ b/scripts/config/lxdialog/Makefile
@@ -7,7 +7,14 @@ all: lxdialog
# we really need to do so. (Do not call gcc as part of make mrproper)
CFLAGS := $(shell sh check-lxdialog.sh -ccflags)
LIBS := $(shell sh check-lxdialog.sh -ldflags gcc)
-
+
+# workaround for OpenBSD, which does not use symlinks to libncurses.so
+OS := $(shell uname -s)
+ifeq ($(strip $(OS)),OpenBSD)
+LIBS := -lncurses
+endif
+
+
always := $(hostprogs-y) dochecklxdialog
%.o: %.c
diff --git a/scripts/config/lxdialog/check-lxdialog.sh b/scripts/config/lxdialog/check-lxdialog.sh
index 50c5ff358b..9a6c915e5a 100644
--- a/scripts/config/lxdialog/check-lxdialog.sh
+++ b/scripts/config/lxdialog/check-lxdialog.sh
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/usr/bin/env bash
# Check ncurses compatibility
# What library to link