summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/toplevel.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index e9384aebca..b215e41afd 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -133,6 +133,13 @@ prereq:: prepare-tmpinfo .config
@+$(NO_TRACE_MAKE) -r -s $@
%::
+ @( \
+ cp .config tmp/.config; \
+ ./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
+ if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
+ echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
+ fi \
+ )
@+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
@+$(SUBMAKE) -r $@