summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index a9ca3a2806..3e39165349 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -16,7 +16,7 @@ include $(TOPDIR)/include/verbose.mk
ifneq ($(VERSION),)
OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
else
- REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+ REV:=$(if $(wildcard .svn/entries),$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' ))
ifneq ($(REV),)
OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
endif