summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/unpack.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index e533476b52..7813e3b3d3 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -17,4 +17,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
else
# try to autodetect file type
endif
+ ifneq ($(strip $(CRLF_WORKAROUND)),)
+ PKG_UNPACK += && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+ endif
endif