summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xscripts/deptest.sh2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/deptest.sh b/scripts/deptest.sh
index ad378bafcd..3a81659f7b 100755
--- a/scripts/deptest.sh
+++ b/scripts/deptest.sh
@@ -22,6 +22,8 @@ die()
[ -f "$BASEDIR/include/toplevel.mk" ] || \
die "Error: Could not find buildsystem base directory"
+[ -f "$BASEDIR/.config" ] || \
+ die "The buildsystem is not configured. Please run make menuconfig."
cd "$BASEDIR" || die "Failed to enter base directory"
mkdir -p "$STAMP_DIR_SUCCESS" "$STAMP_DIR_FAILED" "$BUILD_DIR" "$BUILD_DIR_HOST" "$LOG_DIR"