summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/toolchain-build.mk1
-rw-r--r--toolchain/binutils/Makefile4
2 files changed, 5 insertions, 0 deletions
diff --git a/include/toolchain-build.mk b/include/toolchain-build.mk
index 08054ac9c6..6defe63edf 100644
--- a/include/toolchain-build.mk
+++ b/include/toolchain-build.mk
@@ -7,6 +7,7 @@
override CONFIG_AUTOREBUILD=
+REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index d24151db2a..91d982c002 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -46,6 +46,10 @@ BINUTILS_CONFIGURE:= \
--disable-multilib \
--disable-werror \
--disable-nls \
+ $(if $(CONFIG_GCC_VERSION_4_4), \
+ --with-ppl=$(REAL_STAGING_DIR_HOST) \
+ --with-cloog=$(REAL_STAGING_DIR_HOST) \
+ ) \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \