summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/modules/other.mk1
-rw-r--r--target/linux/x86-2.6/config/default11
2 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index a30046daf5..d15d81c07d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -169,6 +169,7 @@ define KernelPackage/pcmcia-core/2.6
KCONFIG:=$(CONFIG_PCCARD)
FILES:= \
$(LINUX_DIR)/drivers/pcmcia/pcmcia_core.$(LINUX_KMOD_SUFFIX) \
+ $(if $(CONFIG_PCMCIA),$(LINUX_DIR)/drivers/pcmcia/pcmcia.$(LINUX_KMOD_SUFFIX)) \
$(LINUX_DIR)/drivers/pcmcia/yenta_socket.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,40,pcmcia_core pcmcia rsrc_nonstatic yenta_socket)
diff --git a/target/linux/x86-2.6/config/default b/target/linux/x86-2.6/config/default
index e72bb7453e..07219c1411 100644
--- a/target/linux/x86-2.6/config/default
+++ b/target/linux/x86-2.6/config/default
@@ -10,6 +10,7 @@ CONFIG_8139TOO_PIO=y
# CONFIG_ACQUIRE_WDT is not set
# CONFIG_ADVANTECH_WDT is not set
# CONFIG_AGP is not set
+# CONFIG_AIRO_CS is not set
# CONFIG_ALIM1535_WDT is not set
# CONFIG_ALIM7101_WDT is not set
# CONFIG_APRICOT is not set
@@ -43,6 +44,7 @@ CONFIG_BLK_DEV_GENERIC=y
# CONFIG_BLK_DEV_HPT366 is not set
CONFIG_BLK_DEV_IDE=y
# CONFIG_BLK_DEV_IDECD is not set
+# CONFIG_BLK_DEV_IDECS is not set
CONFIG_BLK_DEV_IDEDISK=y
CONFIG_BLK_DEV_IDEDMA=y
# CONFIG_BLK_DEV_IDEDMA_FORCED is not set
@@ -122,6 +124,7 @@ CONFIG_GENERIC_ISA_DMA=y
# CONFIG_HANGCHECK_TIMER is not set
# CONFIG_HIGHMEM4G is not set
# CONFIG_HIGHMEM64G is not set
+# CONFIG_HOSTAP_CS is not set
# CONFIG_HPET_TIMER is not set
# CONFIG_HUGETLBFS is not set
CONFIG_HWMON=m
@@ -169,6 +172,7 @@ CONFIG_I2C_ISA=m
# CONFIG_I2C_VIAPRO is not set
# CONFIG_I2C_VOODOO3 is not set
# CONFIG_I6300ESB_WDT is not set
+# CONFIG_I82365 is not set
# CONFIG_I8K is not set
# CONFIG_I8XX_TCO is not set
# CONFIG_IB700_WDT is not set
@@ -319,6 +323,7 @@ CONFIG_PAGE_OFFSET=0xC0000000
# CONFIG_PATA_OLDPIIX is not set
# CONFIG_PATA_OPTI is not set
# CONFIG_PATA_OPTIDMA is not set
+# CONFIG_PATA_PCMCIA is not set
# CONFIG_PATA_PDC2027X is not set
# CONFIG_PATA_PDC_OLD is not set
# CONFIG_PATA_QDI is not set
@@ -340,6 +345,10 @@ CONFIG_PCI_GOANY=y
# CONFIG_PCI_GOBIOS is not set
# CONFIG_PCI_GODIRECT is not set
# CONFIG_PCI_GOMMCONFIG is not set
+CONFIG_PCMCIA=m
+# CONFIG_PCMCIA_ATMEL is not set
+CONFIG_PCMCIA_IOCTL=y
+CONFIG_PCMCIA_LOAD_CIS=y
CONFIG_PCMCIA_PROBE=y
# CONFIG_PCWATCHDOG is not set
# CONFIG_PDC_ADMA is not set
@@ -449,6 +458,7 @@ CONFIG_SENSORS_PC87360=m
# CONFIG_SENSORS_W83791D is not set
# CONFIG_SENSORS_W83792D is not set
# CONFIG_SENSORS_W83L785TS is not set
+# CONFIG_SERIAL_8250_CS is not set
# CONFIG_SERIAL_8250_EXTENDED is not set
# CONFIG_SERIAL_8250_PNP is not set
CONFIG_SERIO=y
@@ -496,6 +506,7 @@ CONFIG_SERIO_SERPORT=y
CONFIG_SOFT_WATCHDOG=m
# CONFIG_SONYPI is not set
CONFIG_SPARSEMEM_STATIC=y
+# CONFIG_TCIC is not set
# CONFIG_TELCLOCK is not set
# CONFIG_TOSHIBA is not set
# CONFIG_TYPHOON is not set