summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/kirkwood/patches-3.18/180-goflexhome.patch26
-rw-r--r--target/linux/kirkwood/patches-3.18/181-goflexnet.patch25
2 files changed, 35 insertions, 16 deletions
diff --git a/target/linux/kirkwood/patches-3.18/180-goflexhome.patch b/target/linux/kirkwood/patches-3.18/180-goflexhome.patch
index 0560073660..e30a8b1ee9 100644
--- a/target/linux/kirkwood/patches-3.18/180-goflexhome.patch
+++ b/target/linux/kirkwood/patches-3.18/180-goflexhome.patch
@@ -1,5 +1,7 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
+Index: linux-3.18.27/arch/arm/boot/dts/Makefile
+===================================================================
+--- linux-3.18.27.orig/arch/arm/boot/dts/Makefile
++++ linux-3.18.27/arch/arm/boot/dts/Makefile
@@ -120,6 +120,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
kirkwood-ds411.dtb \
kirkwood-ds411j.dtb \
@@ -8,9 +10,11 @@
kirkwood-goflexnet.dtb \
kirkwood-guruplug-server-plus.dtb \
kirkwood-ib62x0.dtb \
+Index: linux-3.18.27/arch/arm/boot/dts/kirkwood-goflexhome.dts
+===================================================================
--- /dev/null
-+++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
-@@ -0,0 +1,127 @@
++++ linux-3.18.27/arch/arm/boot/dts/kirkwood-goflexhome.dts
+@@ -0,0 +1,117 @@
+/dts-v1/;
+
+#include "kirkwood.dtsi"
@@ -109,18 +113,8 @@
+ };
+
+ partition@100000 {
-+ label = "uImage";
-+ reg = <0x0100000 0x400000>;
-+ };
-+
-+ partition@500000 {
-+ label = "pogoplug";
-+ reg = <0x0500000 0x2000000>;
-+ };
-+
-+ partition@2500000 {
-+ label = "root";
-+ reg = <0x02500000 0xd800000>;
++ label = "ubi";
++ reg = <0x100000 0xfc00000>;
+ };
+};
+
diff --git a/target/linux/kirkwood/patches-3.18/181-goflexnet.patch b/target/linux/kirkwood/patches-3.18/181-goflexnet.patch
new file mode 100644
index 0000000000..9fe62d18d1
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/181-goflexnet.patch
@@ -0,0 +1,25 @@
+Index: linux-4.4.4/arch/arm/boot/dts/kirkwood-goflexnet.dts
+===================================================================
+--- linux-4.4.4.orig/arch/arm/boot/dts/kirkwood-goflexnet.dts
++++ linux-4.4.4/arch/arm/boot/dts/kirkwood-goflexnet.dts
+@@ -158,18 +158,8 @@
+ };
+
+ partition@100000 {
+- label = "uImage";
+- reg = <0x0100000 0x400000>;
+- };
+-
+- partition@500000 {
+- label = "pogoplug";
+- reg = <0x0500000 0x2000000>;
+- };
+-
+- partition@2500000 {
+- label = "root";
+- reg = <0x02500000 0xd800000>;
++ label = "ubi";
++ reg = <0x0100000 0xfc00000>;
+ };
+ };
+