summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/hostapd/Makefile2
-rw-r--r--rules.mk5
2 files changed, 5 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 322f881781..31ef18d8be 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -20,7 +20,7 @@ PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_BUILD_DEPENDS:=madwifi mac80211
include $(INCLUDE_DIR)/package.mk
-STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,PACKAGE_kmod-mac80211 PACKAGE_kmod-madwifi)
+$(eval $(call confvar,STAMP_CONFIGURED,CONFIG_PACKAGE_kmod-mac80211 CONFIG_PACKAGE_kmod-madwifi))
define Package/hostapd/Default
SECTION:=net
diff --git a/rules.mk b/rules.mk
index 4a0fa32e35..14ff5acdf2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -139,7 +139,10 @@ export $(call shvar,$(1))
endef
define confvar
-$(foreach v,$(1),$(if $($(v)),y,n))
+$(1):=$$(strip $$($(1)))_
+$(foreach v,$(2),
+ $(1):=$$(strip $$($(1)))$(if $($(v)),y,n)
+)
endef
# file extension