summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 020779fd63..4744e09ef6 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -48,7 +48,11 @@ else
LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE)),)
- LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING)
+ ifeq ($(word 1,$(subst ., ,$(KERNEL_BASE))),3)
+ LINUX_SITE:=@KERNEL/linux/kernel/v3.x$(TESTING)
+ else
+ LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING)
+ endif
endif
ifneq ($(TARGET_BUILD),1)