summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/utils/curl/Config.in5
-rw-r--r--package/network/utils/curl/Makefile4
2 files changed, 8 insertions, 1 deletions
diff --git a/package/network/utils/curl/Config.in b/package/network/utils/curl/Config.in
index f41307a970..14d2047301 100644
--- a/package/network/utils/curl/Config.in
+++ b/package/network/utils/curl/Config.in
@@ -154,4 +154,9 @@ config LIBCURL_VERBOSE
bool "Enable verbose error strings"
default n
+config LIBCURL_NTLM
+ bool "Enable NTLM support"
+ depends LIBCURL_CRYPTO_AUTH && !LIBCURL_NOSSL
+ default n
+
endif
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index eada1aa596..319c0b710d 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -65,7 +65,8 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_LIBCURL_THREADED_RESOLVER \
CONFIG_LIBCURL_TLS_SRP \
CONFIG_LIBCURL_UNIX_SOCKETS \
- CONFIG_LIBCURL_VERBOSE
+ CONFIG_LIBCURL_VERBOSE \
+ CONFIG_LIBCURL_NTLM
include $(INCLUDE_DIR)/package.mk
@@ -99,6 +100,7 @@ define Package/libcurl/config
endef
TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
CONFIGURE_ARGS += \
--disable-debug \