summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-4.0/259-regmap_dynamic.patch2
-rw-r--r--target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch18
-rw-r--r--target/linux/generic/patches-4.0/668-fix-ipv6-throw-routes.patch31
-rw-r--r--target/linux/generic/patches-4.0/834-ledtrig-libata.patch2
-rw-r--r--target/linux/generic/patches-4.0/863-gpiommc.patch2
6 files changed, 11 insertions, 48 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 6421acb455..8c3d371766 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,14 +7,14 @@ LINUX_VERSION-3.10 = .58
LINUX_VERSION-3.13 = .7
LINUX_VERSION-3.14 = .35
LINUX_VERSION-3.18 = .10
-LINUX_VERSION-4.0 = -rc5
+LINUX_VERSION-4.0 = -rc6
LINUX_KERNEL_MD5SUM-3.8.13 = 2af19d06cd47ec459519159cdd10542d
LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
LINUX_KERNEL_MD5SUM-3.13.7 = 370adced5e5c1cb1d0d621c2dae2723f
LINUX_KERNEL_MD5SUM-3.14.35 = e5e92c40d14bc8ae9a8701db4e1cbb27
LINUX_KERNEL_MD5SUM-3.18.10 = 1e8ad8a122e332e429d4c786ece4582e
-LINUX_KERNEL_MD5SUM-4.0-rc5 = b26150c980099ef554b26d07f470e647
+LINUX_KERNEL_MD5SUM-4.0-rc6 = bec0aeeacab2852d9a17ccbfa7e280f8
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/patches-4.0/259-regmap_dynamic.patch b/target/linux/generic/patches-4.0/259-regmap_dynamic.patch
index 9f93aec901..1e80aa2f2c 100644
--- a/target/linux/generic/patches-4.0/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-4.0/259-regmap_dynamic.patch
@@ -75,7 +75,7 @@
#include <linux/mutex.h>
#include <linux/err.h>
#include <linux/of.h>
-@@ -2636,3 +2637,5 @@ static int __init regmap_initcall(void)
+@@ -2632,3 +2633,5 @@ static int __init regmap_initcall(void)
return 0;
}
postcore_initcall(regmap_initcall);
diff --git a/target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch b/target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
index 787aef5b05..41454c945b 100644
--- a/target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
+++ b/target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
@@ -14,10 +14,8 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
net/ipv6/ip6_tunnel.c | 276 +++++++++++++++++++++++++++++++++++++++--
3 files changed, 291 insertions(+), 11 deletions(-)
-Index: linux-4.0-rc5/include/net/ip6_tunnel.h
-===================================================================
---- linux-4.0-rc5.orig/include/net/ip6_tunnel.h
-+++ linux-4.0-rc5/include/net/ip6_tunnel.h
+--- a/include/net/ip6_tunnel.h
++++ b/include/net/ip6_tunnel.h
@@ -15,6 +15,18 @@
/* determine capability on a per-packet basis */
#define IP6_TNL_F_CAP_PER_PACKET 0x40000
@@ -45,10 +43,8 @@ Index: linux-4.0-rc5/include/net/ip6_tunnel.h
__be16 i_flags;
__be16 o_flags;
-Index: linux-4.0-rc5/include/uapi/linux/if_tunnel.h
-===================================================================
---- linux-4.0-rc5.orig/include/uapi/linux/if_tunnel.h
-+++ linux-4.0-rc5/include/uapi/linux/if_tunnel.h
+--- a/include/uapi/linux/if_tunnel.h
++++ b/include/uapi/linux/if_tunnel.h
@@ -57,10 +57,23 @@ enum {
IFLA_IPTUN_ENCAP_FLAGS,
IFLA_IPTUN_ENCAP_SPORT,
@@ -73,10 +69,8 @@ Index: linux-4.0-rc5/include/uapi/linux/if_tunnel.h
enum tunnel_encap_types {
TUNNEL_ENCAP_NONE,
TUNNEL_ENCAP_FOU,
-Index: linux-4.0-rc5/net/ipv6/ip6_tunnel.c
-===================================================================
---- linux-4.0-rc5.orig/net/ipv6/ip6_tunnel.c
-+++ linux-4.0-rc5/net/ipv6/ip6_tunnel.c
+--- a/net/ipv6/ip6_tunnel.c
++++ b/net/ipv6/ip6_tunnel.c
@@ -16,6 +16,8 @@
* as published by the Free Software Foundation; either version
* 2 of the License, or (at your option) any later version.
diff --git a/target/linux/generic/patches-4.0/668-fix-ipv6-throw-routes.patch b/target/linux/generic/patches-4.0/668-fix-ipv6-throw-routes.patch
deleted file mode 100644
index 283ffce911..0000000000
--- a/target/linux/generic/patches-4.0/668-fix-ipv6-throw-routes.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 9cd600244515bd4540898411ab781a97f0cc387f Mon Sep 17 00:00:00 2001
-From: Steven Barth <steven@midlink.org>
-Date: Thu, 19 Mar 2015 11:54:50 +0100
-Subject: [PATCH] ipv6: fix backtracking for throw routes
-
-for throw routes to trigger evaluation of other policy rules
-EAGAIN needs to be propagated up to fib_rules_lookup
-similar to how its done for IPv4
-
-A simple testcase for verification is:
-
-ip -6 rule add lookup 33333 priority 33333
-ip -6 route add throw 2001:db8::1
-ip -6 route add 2001:db8::1 via fe80::1 dev wlan0 table 33333
-ip route get 2001:db8::1
-
-Signed-off-by: Steven Barth <cyrus@openwrt.org>
----
- net/ipv6/fib6_rules.c | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/net/ipv6/fib6_rules.c
-+++ b/net/ipv6/fib6_rules.c
-@@ -104,6 +104,7 @@ static int fib6_rule_action(struct fib_r
- goto again;
- flp6->saddr = saddr;
- }
-+ err = rt->dst.error;
- goto out;
- }
- again:
diff --git a/target/linux/generic/patches-4.0/834-ledtrig-libata.patch b/target/linux/generic/patches-4.0/834-ledtrig-libata.patch
index 787b37774b..b59483ec25 100644
--- a/target/linux/generic/patches-4.0/834-ledtrig-libata.patch
+++ b/target/linux/generic/patches-4.0/834-ledtrig-libata.patch
@@ -138,7 +138,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
/*
* Define if arch has non-standard setup. This is a _PCI_ standard
-@@ -864,6 +867,12 @@ struct ata_port {
+@@ -865,6 +868,12 @@ struct ata_port {
#ifdef CONFIG_ATA_ACPI
struct ata_acpi_gtm __acpi_init_gtm; /* use ata_acpi_init_gtm() */
#endif
diff --git a/target/linux/generic/patches-4.0/863-gpiommc.patch b/target/linux/generic/patches-4.0/863-gpiommc.patch
index 5fd329783d..b46f876678 100644
--- a/target/linux/generic/patches-4.0/863-gpiommc.patch
+++ b/target/linux/generic/patches-4.0/863-gpiommc.patch
@@ -830,7 +830,7 @@
+be done automatically.
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -4474,6 +4474,11 @@ T: git git://linuxtv.org/anttip/media_tr
+@@ -4482,6 +4482,11 @@ T: git git://linuxtv.org/anttip/media_tr
S: Maintained
F: drivers/media/usb/hackrf/