summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/host-build.mk8
-rw-r--r--include/quilt.mk10
2 files changed, 12 insertions, 6 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a6118fb06f..3d1983b28f 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -13,7 +13,7 @@ include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
BUILD_TYPES += host
-HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
+HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(HOST_QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.$(PKG_NAME)_installed
@@ -78,7 +78,7 @@ define Host/Compile
$(call Host/Compile/Default)
endef
-ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
+ifneq ($(if $(HOST_QUILT),,$(CONFIG_AUTOREBUILD)),)
define HostHost/Autoclean
$(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(HOST_STAMP_PREPARED))
$(if $(if $(Host/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(HOST_BUILD_DIR),$(HOST_STAMP_BUILT)))
@@ -96,7 +96,7 @@ endef
ifndef DUMP
define HostBuild
- $(if $(QUILT),$(Host/Quilt))
+ $(if $(HOST_QUILT),$(Host/Quilt))
$(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
$(if $(DUMP),,$(call HostHost/Autoclean))
@@ -128,6 +128,8 @@ ifndef DUMP
compile: host-compile
install: host-install
clean: host-clean
+ else
+ host-compile: $(HOST_STAMP_INSTALLED)
endif
host-prepare: $(HOST_STAMP_PREPARED)
host-configure: $(HOST_STAMP_CONFIGURED)
diff --git a/include/quilt.mk b/include/quilt.mk
index fbb3e01e35..32a62fb0df 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -55,6 +55,10 @@ define PatchDir
$(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
endef
+define HostPatchDir
+$(call PatchDir/$(if $(strip $(HOST_QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
+endef
+
ifneq ($(PKG_BUILD_DIR),)
QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
ifneq ($(QUILT),)
@@ -78,9 +82,9 @@ ifneq ($(HOST_BUILD_DIR),)
endif
define Host/Patch/Default
- $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
- $(call PatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
- $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
+ $(if $(HOST_QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
+ $(call HostPatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
+ $(if $(HOST_QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
endef
define Build/Patch/Default