summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/usb.mk38
-rw-r--r--target/linux/omap24xx/modules.mk37
2 files changed, 38 insertions, 37 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index e1d14a2926..38441e5e0a 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -36,6 +36,44 @@ define AddDepends/usb
endef
+define KernelPackage/musb-hdrc
+ TITLE:=Support for Mentor Graphics silicon dual role USB
+ KCONFIG:= \
+ CONFIG_USB_MUSB_HDRC \
+ CONFIG_MUSB_PIO_ONLY=n \
+ CONFIG_USB_MUSB_OTG=y \
+ CONFIG_USB_MUSB_DEBUG=y
+ DEPENDS:=@TARGET_omap24xx
+ FILES:=$(LINUX_DIR)/drivers/usb/musb/musb_hdrc.ko
+ AUTOLOAD:=$(call AutoLoad,46,musb_hdrc)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/musb-hdrc/description
+ Kernel support for Mentor Graphics silicon dual role USB device.
+endef
+
+$(eval $(call KernelPackage,musb-hdrc))
+
+
+
+define KernelPackage/nop-usb-xceiv
+ TITLE:=Support for USB OTG NOP transceiver
+ KCONFIG:= \
+ CONFIG_NOP_USB_XCEIV
+ DEPENDS:=@TARGET_omap24xx
+ FILES:=$(LINUX_DIR)/drivers/usb/otg/nop-usb-xceiv.ko
+ AUTOLOAD:=$(call AutoLoad,45,nop-usb-xceiv)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/nop-usb-xceiv/description
+ Support for USB OTG NOP transceiver
+endef
+
+$(eval $(call KernelPackage,nop-usb-xceiv))
+
+
define KernelPackage/usb-gadget
TITLE:=USB Gadget support
KCONFIG:=CONFIG_USB_GADGET
diff --git a/target/linux/omap24xx/modules.mk b/target/linux/omap24xx/modules.mk
index 182c5f19c0..4c73ab7c77 100644
--- a/target/linux/omap24xx/modules.mk
+++ b/target/linux/omap24xx/modules.mk
@@ -63,43 +63,6 @@ endef
$(eval $(call KernelPackage,n810bm))
-define KernelPackage/musb-hdrc
- TITLE:=Support for Mentor Graphics silicon dual role USB
- KCONFIG:= \
- CONFIG_USB_MUSB_HDRC \
- CONFIG_MUSB_PIO_ONLY=n \
- CONFIG_USB_MUSB_OTG=y \
- CONFIG_USB_MUSB_DEBUG=y
- DEPENDS:=@TARGET_omap24xx
- FILES:=$(LINUX_DIR)/drivers/usb/musb/musb_hdrc.ko
- AUTOLOAD:=$(call AutoLoad,46,musb_hdrc)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/musb-hdrc/description
- Kernel support for Mentor Graphics silicon dual role USB device.
-endef
-
-$(eval $(call KernelPackage,musb-hdrc))
-
-
-define KernelPackage/nop-usb-xceiv
- TITLE:=Support for USB OTG NOP transceiver
- KCONFIG:= \
- CONFIG_NOP_USB_XCEIV
- DEPENDS:=@TARGET_omap24xx
- FILES:=$(LINUX_DIR)/drivers/usb/otg/nop-usb-xceiv.ko
- AUTOLOAD:=$(call AutoLoad,45,nop-usb-xceiv)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/nop-usb-xceiv/description
- Support for USB OTG NOP transceiver
-endef
-
-$(eval $(call KernelPackage,nop-usb-xceiv))
-
-
define KernelPackage/tusb6010
TITLE:=Support for TUSB 6010
KCONFIG:= \