summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/gmp/Makefile28
-rw-r--r--tools/mpfr/Makefile26
2 files changed, 9 insertions, 45 deletions
diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
index 4c6fac425f..3356ae9dd1 100644
--- a/tools/gmp/Makefile
+++ b/tools/gmp/Makefile
@@ -15,28 +15,10 @@ PKG_MD5SUM:=
include $(INCLUDE_DIR)/host-build.mk
-define Host/Configure
- (cd $(HOST_BUILD_DIR); \
- ./configure \
- --prefix=$(STAGING_DIR_HOST) \
- --build=$(GNU_HOST_NAME) \
- --enable-static \
- --disable-shared \
- --enable-cxx \
- --enable-mpbsd \
- );
-endef
-
-define Host/Compile
- make -C $(HOST_BUILD_DIR) all
-endef
-
-define Host/Install
- make -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
- rm -rf $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --enable-cxx \
+ --enable-mpbsd
$(eval $(call HostBuild))
diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
index 5abb2a2c79..17734a246a 100644
--- a/tools/mpfr/Makefile
+++ b/tools/mpfr/Makefile
@@ -15,27 +15,9 @@ PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
include $(INCLUDE_DIR)/host-build.mk
-define Host/Configure
- (cd $(HOST_BUILD_DIR); \
- ./configure \
- --prefix=$(STAGING_DIR_HOST) \
- --build=$(GNU_HOST_NAME) \
- --enable-static \
- --disable-shared \
- --with-gmp=$(STAGING_DIR_HOST) \
- );
-endef
-
-define Host/Compile
- make -C $(HOST_BUILD_DIR) all
-endef
-
-define Host/Install
- make -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
- rm -rf $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp=$(STAGING_DIR_HOST)
$(eval $(call HostBuild))