summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/netsupport.mk2
-rw-r--r--target/linux/generic/patches-3.18/263-udp_tunnel_kconfig_hack.patch11
-rw-r--r--target/linux/generic/patches-4.1/263-udp_tunnel_kconfig_hack.patch11
-rw-r--r--target/linux/generic/patches-4.4/263-udp_tunnel_kconfig_hack.patch11
4 files changed, 2 insertions, 33 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 2d574751e5..cf1de6a894 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -149,6 +149,7 @@ define KernelPackage/udptunnel4
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPv4 UDP tunneling support
KCONFIG:=CONFIG_NET_UDP_TUNNEL
+ HIDDEN:=1
FILES:=$(LINUX_DIR)/net/ipv4/udp_tunnel.ko
AUTOLOAD:=$(call AutoLoad,32,udp_tunnel)
endef
@@ -161,6 +162,7 @@ define KernelPackage/udptunnel6
TITLE:=IPv6 UDP tunneling support
DEPENDS:=@IPV6
KCONFIG:=CONFIG_NET_UDP_TUNNEL
+ HIDDEN:=1
FILES:=$(LINUX_DIR)/net/ipv6/ip6_udp_tunnel.ko
AUTOLOAD:=$(call AutoLoad,32,ip6_udp_tunnel)
endef
diff --git a/target/linux/generic/patches-3.18/263-udp_tunnel_kconfig_hack.patch b/target/linux/generic/patches-3.18/263-udp_tunnel_kconfig_hack.patch
deleted file mode 100644
index e8fb296698..0000000000
--- a/target/linux/generic/patches-3.18/263-udp_tunnel_kconfig_hack.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/net/ipv4/Kconfig
-+++ b/net/ipv4/Kconfig
-@@ -308,7 +308,7 @@ config NET_IPVTI
- on top.
-
- config NET_UDP_TUNNEL
-- tristate
-+ tristate "IP: UDP tunnel"
- select NET_IP_TUNNEL
- default n
-
diff --git a/target/linux/generic/patches-4.1/263-udp_tunnel_kconfig_hack.patch b/target/linux/generic/patches-4.1/263-udp_tunnel_kconfig_hack.patch
deleted file mode 100644
index e8fb296698..0000000000
--- a/target/linux/generic/patches-4.1/263-udp_tunnel_kconfig_hack.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/net/ipv4/Kconfig
-+++ b/net/ipv4/Kconfig
-@@ -308,7 +308,7 @@ config NET_IPVTI
- on top.
-
- config NET_UDP_TUNNEL
-- tristate
-+ tristate "IP: UDP tunnel"
- select NET_IP_TUNNEL
- default n
-
diff --git a/target/linux/generic/patches-4.4/263-udp_tunnel_kconfig_hack.patch b/target/linux/generic/patches-4.4/263-udp_tunnel_kconfig_hack.patch
deleted file mode 100644
index e8fb296698..0000000000
--- a/target/linux/generic/patches-4.4/263-udp_tunnel_kconfig_hack.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/net/ipv4/Kconfig
-+++ b/net/ipv4/Kconfig
-@@ -308,7 +308,7 @@ config NET_IPVTI
- on top.
-
- config NET_UDP_TUNNEL
-- tristate
-+ tristate "IP: UDP tunnel"
- select NET_IP_TUNNEL
- default n
-