summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/host.mk1
-rw-r--r--rules.mk1
2 files changed, 1 insertions, 1 deletions
diff --git a/include/host.mk b/include/host.mk
index ed961e35d9..1130d5b9a6 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -11,6 +11,7 @@ export TAR
$(TMP_DIR)/.host.mk: $(INCLUDE_DIR)/host.mk
@( \
+ echo -n "BASH:=$(shell which bash)"; \
HOST_OS=`uname`; \
case "$$HOST_OS" in \
Linux) HOST_ARCH=`uname -m`;; \
diff --git a/rules.mk b/rules.mk
index da0e04c1c4..d52539f3f2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -9,7 +9,6 @@
include $(TOPDIR)/include/verbose.mk
export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
-export BASH=$(shell which bash)
ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))