summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel.mk1
-rw-r--r--include/package-ipkg.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 20377af3cf..cb62e63810 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -77,6 +77,7 @@ define ModuleAutoLoad
$(3) \
if [ -n "$$$$$$$$modules" ]; then \
mkdir -p $(2)/etc/modules.d; \
+ mkdir -p $(2)/CONTROL; \
echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
echo ". /etc/functions.sh" >> $(2)/CONTROL/postinst; \
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 4af052c37a..72d6d596b7 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -90,6 +90,7 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(STAGING_DIR)/etc/ipkg.conf $(STAMP_BUILT) $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
+ mkdir -p $$(IDIR_$(1))/CONTROL
mkdir -p $(PACKAGE_DIR)
-find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
$(RSTRIP) $$(IDIR_$(1))