summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/host-build.mk4
-rw-r--r--include/package.mk2
-rw-r--r--include/unpack.mk6
3 files changed, 6 insertions, 6 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 858eee5318..0502d7682a 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -8,9 +8,9 @@
include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
-ifneq ($(strip $(UNPACK)),)
+ifneq ($(strip $(PKG_UNPACK)),)
define Build/Prepare/Default
- $(UNPACK)
+ $(PKG_UNPACK)
@if [ -d ./patches ]; then \
$(PATCH) $(PKG_BUILD_DIR) ./patches; \
fi
diff --git a/include/package.mk b/include/package.mk
index fc1b7802f9..706b38d12a 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -272,7 +272,7 @@ endef
ifneq ($(strip $(PKG_UNPACK)),)
define Build/Prepare/Default
- $(UNPACK)
+ $(PKG_UNPACK)
@if [ -d ./patches ]; then \
$(PATCH) $(PKG_BUILD_DIR) ./patches; \
fi
diff --git a/include/unpack.mk b/include/unpack.mk
index 6449981c1b..52764e492e 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -1,13 +1,13 @@
ifeq ($(strip $(PKG_UNPACK)),)
ifneq ($(strip $(PKG_CAT)),)
# use existing PKG_CAT
- UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
ifeq ($(PKG_CAT),unzip)
- UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+ PKG_UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
endif
# replace zcat with $(ZCAT), because some system have it as gzcat
ifeq ($(PKG_CAT),zcat)
- UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ PKG_UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
endif
else
# try to autodetect file type