summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/dts/WF-2881.dts14
-rw-r--r--target/linux/ramips/image/Makefile5
2 files changed, 5 insertions, 14 deletions
diff --git a/target/linux/ramips/dts/WF-2881.dts b/target/linux/ramips/dts/WF-2881.dts
index aaafe5af82..d33436c64a 100644
--- a/target/linux/ramips/dts/WF-2881.dts
+++ b/target/linux/ramips/dts/WF-2881.dts
@@ -48,19 +48,9 @@
read-only;
};
- firmware {
- label = "firmware";
- reg = <0x140000 0x6EC0000>;
- };
-
partition@140000 {
- label = "kernel";
- reg = <0x140000 0x200000>;
- };
-
- partition@340000 {
- label = "ubi";
- reg = <0x340000 0x6CC0000>;
+ label = "firmware";
+ reg = <0x140000 0x7E40000>;
};
};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index eb50cddeaf..f5e8e58ef9 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -1115,9 +1115,10 @@ define Device/wf-2881
DTS := WF-2881
BLOCKSIZE := 128KiB
PAGESIZE := 2048
- KERNEL_SIZE := 2097152
FILESYSTEMS := squashfs
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+ IMAGE_SIZE := 132382720
+ KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
+ IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
endef
define Device/ubnt-erx