summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile3
-rw-r--r--package/Makefile2
-rwxr-xr-xscripts/feeds.sh8
3 files changed, 6 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 84c8c51156..35fc2c8884 100644
--- a/Makefile
+++ b/Makefile
@@ -187,9 +187,6 @@ doc:
docclean:
$(MAKE) -C docs/ clean
-symlinks:
- scripts/feeds.sh $(CONFIG_SOURCE_FEEDS)
-
.SILENT: clean dirclean distclean config-clean download world
FORCE: ;
.PHONY: FORCE help
diff --git a/package/Makefile b/package/Makefile
index cd4304e667..d21fedf31b 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -73,6 +73,8 @@ index: $(PACKAGE_DIR)/Packages
$(PACKAGE_DIR)/Packages: $(PACKAGE_DIR)/*.ipk
(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+symlinks:
+ ../scripts/feeds.sh $(CONFIG_SOURCE_FEEDS)
ifeq ($(MAKECMDGOALS),compile-targets)
MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
diff --git a/scripts/feeds.sh b/scripts/feeds.sh
index a16b212c80..351c87c43d 100755
--- a/scripts/feeds.sh
+++ b/scripts/feeds.sh
@@ -28,16 +28,16 @@ delete_symlinks() {
setup_symlinks() {
# We assume that feeds do reproduce the hierarchy : section/package
# so that we can make this structure be flat in $PACKAGE_DIR
- for dir in $(ls $2/)
+ for dir in $(ls $1/)
do
- ln -s $2/$dir/*/* $1/
+ ln -s $1/$dir/*/* $2/
done
}
checkout_feed() {
# We ensure the feed has not already been checked out, if so, we just update the source feed
if [ -d $FEEDS_DIR/$2 ]; then
- svn update $FEEDS_DIR/$2
+ svn up $FEEDS_DIR/$2
echo "Updated to revision $(LANG=C svn info $FEEDS_DIR/$2 | awk '/^Revision:/ { print $2 }' )";
# Otherwise, we have to checkout in the $FEEDS_DIR
else
@@ -48,7 +48,7 @@ checkout_feed() {
extract_feed_name() {
# We extract the last name of the URL, maybe we should rename this as domain.tld.repository.name
- echo "$(echo $1 | awk -F/ '{ print $NF}')"
+ echo "$(echo $1 | sed -e "s/[^A-Za-z\.]\+/_/g")"
}
# We can delete symlinks every time we start this script, since modifications have been made in the $FEEDS_DIR anyway