summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-4.1/091-mtd-spi-nor-add-support-Spansion_S25FL164K8
-rw-r--r--target/linux/generic/patches-4.1/630-packet_socket_type.patch16
-rw-r--r--target/linux/generic/patches-4.1/702-phy_add_aneg_done_function.patch2
-rw-r--r--target/linux/generic/patches-4.1/704-phy-no-genphy-soft-reset.patch6
5 files changed, 17 insertions, 19 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 3f3c52faf1..3aac242079 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .18
LINUX_VERSION-4.0 = .8
-LINUX_VERSION-4.1 = .1
+LINUX_VERSION-4.1 = .2
LINUX_KERNEL_MD5SUM-3.18.18 = 6fce868a56f2d83f80cdad5fed457110
LINUX_KERNEL_MD5SUM-4.0.8 = a99375dd855de00635e9ac8e62b0f8e6
-LINUX_KERNEL_MD5SUM-4.1.1 = bf83da42349ab7fe77c61b5d10d9f003
+LINUX_KERNEL_MD5SUM-4.1.2 = 26879db288cd9ffa17c9fd5db213b272
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/patches-4.1/091-mtd-spi-nor-add-support-Spansion_S25FL164K b/target/linux/generic/patches-4.1/091-mtd-spi-nor-add-support-Spansion_S25FL164K
index d28fbc6081..c8aa336661 100644
--- a/target/linux/generic/patches-4.1/091-mtd-spi-nor-add-support-Spansion_S25FL164K
+++ b/target/linux/generic/patches-4.1/091-mtd-spi-nor-add-support-Spansion_S25FL164K
@@ -1,8 +1,6 @@
-Index: linux-4.1.1/drivers/mtd/spi-nor/spi-nor.c
-===================================================================
---- linux-4.1.1.orig/drivers/mtd/spi-nor/spi-nor.c
-+++ linux-4.1.1/drivers/mtd/spi-nor/spi-nor.c
-@@ -618,6 +618,7 @@ static const struct spi_device_id spi_no
+--- a/drivers/mtd/spi-nor/spi-nor.c
++++ b/drivers/mtd/spi-nor/spi-nor.c
+@@ -614,6 +614,7 @@ static const struct spi_device_id spi_no
{ "s25fl016k", INFO(0xef4015, 0, 64 * 1024, 32, SECT_4K) },
{ "s25fl064k", INFO(0xef4017, 0, 64 * 1024, 128, SECT_4K) },
{ "s25fl132k", INFO(0x014016, 0, 64 * 1024, 64, 0) },
diff --git a/target/linux/generic/patches-4.1/630-packet_socket_type.patch b/target/linux/generic/patches-4.1/630-packet_socket_type.patch
index 7d034d7605..9fb9a400ee 100644
--- a/target/linux/generic/patches-4.1/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-4.1/630-packet_socket_type.patch
@@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#define PACKET_FANOUT_LB 1
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
-@@ -1547,6 +1547,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1533,6 +1533,7 @@ static int packet_rcv_spkt(struct sk_buf
{
struct sock *sk;
struct sockaddr_pkt *spkt;
@@ -34,7 +34,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* When we registered the protocol we saved the socket in the data
-@@ -1554,6 +1555,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1540,6 +1541,7 @@ static int packet_rcv_spkt(struct sk_buf
*/
sk = pt->af_packet_priv;
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* Yank back the headers [hope the device set this
-@@ -1566,7 +1568,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1552,7 +1554,7 @@ static int packet_rcv_spkt(struct sk_buf
* so that this procedure is noop.
*/
@@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
goto out;
if (!net_eq(dev_net(dev), sock_net(sk)))
-@@ -1773,12 +1775,12 @@ static int packet_rcv(struct sk_buff *sk
+@@ -1759,12 +1761,12 @@ static int packet_rcv(struct sk_buff *sk
int skb_len = skb->len;
unsigned int snaplen, res;
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -1898,12 +1900,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -1884,12 +1886,12 @@ static int tpacket_rcv(struct sk_buff *s
BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -2866,6 +2868,7 @@ static int packet_create(struct net *net
+@@ -2852,6 +2854,7 @@ static int packet_create(struct net *net
spin_lock_init(&po->bind_lock);
mutex_init(&po->pg_vec_lock);
po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
-@@ -3471,6 +3474,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3457,6 +3460,16 @@ packet_setsockopt(struct socket *sock, i
po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
return 0;
}
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
default:
return -ENOPROTOOPT;
}
-@@ -3522,6 +3535,13 @@ static int packet_getsockopt(struct sock
+@@ -3508,6 +3521,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;
diff --git a/target/linux/generic/patches-4.1/702-phy_add_aneg_done_function.patch b/target/linux/generic/patches-4.1/702-phy_add_aneg_done_function.patch
index d383c5ae79..c743cefc5a 100644
--- a/target/linux/generic/patches-4.1/702-phy_add_aneg_done_function.patch
+++ b/target/linux/generic/patches-4.1/702-phy_add_aneg_done_function.patch
@@ -15,7 +15,7 @@
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -928,6 +928,9 @@ int genphy_update_link(struct phy_device
+@@ -929,6 +929,9 @@ int genphy_update_link(struct phy_device
{
int status;
diff --git a/target/linux/generic/patches-4.1/704-phy-no-genphy-soft-reset.patch b/target/linux/generic/patches-4.1/704-phy-no-genphy-soft-reset.patch
index fa2e59b2ef..41a6d91588 100644
--- a/target/linux/generic/patches-4.1/704-phy-no-genphy-soft-reset.patch
+++ b/target/linux/generic/patches-4.1/704-phy-no-genphy-soft-reset.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -1146,7 +1146,7 @@ int genphy_config_init(struct phy_device
+@@ -1147,7 +1147,7 @@ int genphy_config_init(struct phy_device
return 0;
}
@@ -9,7 +9,7 @@
{
/* Do nothing for now */
return 0;
-@@ -1360,7 +1360,7 @@ static struct phy_driver genphy_driver[]
+@@ -1361,7 +1361,7 @@ static struct phy_driver genphy_driver[]
.phy_id = 0xffffffff,
.phy_id_mask = 0xffffffff,
.name = "Generic PHY",
@@ -18,7 +18,7 @@
.config_init = genphy_config_init,
.features = PHY_GBIT_FEATURES | SUPPORTED_MII |
SUPPORTED_AUI | SUPPORTED_FIBRE |
-@@ -1375,7 +1375,7 @@ static struct phy_driver genphy_driver[]
+@@ -1376,7 +1376,7 @@ static struct phy_driver genphy_driver[]
.phy_id = 0xffffffff,
.phy_id_mask = 0xffffffff,
.name = "Generic 10G PHY",