summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/uboot-lantiq/patches/010-fix-mips-flags.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/uboot-lantiq/patches/010-fix-mips-flags.patch b/package/uboot-lantiq/patches/010-fix-mips-flags.patch
index 4c706a7843..6dd7d8f569 100644
--- a/package/uboot-lantiq/patches/010-fix-mips-flags.patch
+++ b/package/uboot-lantiq/patches/010-fix-mips-flags.patch
@@ -1,6 +1,6 @@
--- a/cpu/mips/config.mk
+++ b/cpu/mips/config.mk
-@@ -23,16 +23,18 @@
+@@ -23,17 +23,19 @@
v=$(shell $(AS) --version | grep 'GNU assembler' | egrep -o '2\.[0-9\.]+' | cut -d. -f2)
MIPSFLAGS:=$(shell \
if [ "$v" -lt "14" ]; then \
@@ -19,5 +19,7 @@
endif
+endif
- MIPSFLAGS += $(ENDIANNESS)
+-MIPSFLAGS += $(ENDIANNESS)
++MIPSFLAGS += $(ENDIANNESS) -fno-schedule-insns -fno-schedule-insns2
+ PLATFORM_CPPFLAGS += $(MIPSFLAGS)