summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xscripts/metadata.pl2
-rw-r--r--target/imagebuilder/files/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index 7514a17135..d27cd8e59d 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -151,7 +151,7 @@ sub gen_target_mk() {
PACKAGES:=".join(" ", @{$profile->{packages}})."
endef";
$profiles_eval .= "
-\$(eval \$(call Profile,$conf\_$profile->{id}))"
+\$(eval \$(call AddProfile,$conf\_$profile->{id}))"
}
print "
ifeq (\$(CONFIG_LINUX_$conf),y)
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index eae3697e81..b36e2f2e31 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -37,7 +37,7 @@ define Profile/Default
PACKAGES:=
endef
-define Profile
+define AddProfile
$(eval $(call Profile/Default))
$(eval $(call Profile/$(1)))
ifneq ($(ID),)