summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/package-defaults.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 9567e04a7a..e37ab88a31 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -67,7 +67,11 @@ ifneq ($(strip $(PKG_UNPACK)),)
endif
EXTRA_CXXFLAGS = $(EXTRA_CFLAGS)
-DISABLE_NLS:=--disable-nls
+ifeq ($(CONFIG_BUILD_NLS),y)
+ DISABLE_NLS:=
+else
+ DISABLE_NLS:=--disable-nls
+endif
CONFIGURE_PREFIX:=/usr
CONFIGURE_ARGS = \