summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/other.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 98b7f54dcf..11d836e5f7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -874,6 +874,21 @@ endef
$(eval $(call KernelPackage,random-core))
+define KernelPackage/random-omap
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Hardware Random Number Generator OMAP support
+ KCONFIG:=CONFIG_HW_RANDOM_OMAP
+ FILES:=$(LINUX_DIR)/drivers/char/hw_random/omap-rng.ko
+ DEPENDS:=@(TARGET_omap24xx||TARGET_omap) +kmod-random-core
+ AUTOLOAD:=$(call AutoProbe,random-omap)
+endef
+
+define KernelPackage/random-omap/description
+ Kernel module for the OMAP Random Number Generator
+ found on OMAP16xx, OMAP2/3/4/5 and AM33xx/AM43xx multimedia processors.
+endef
+
+$(eval $(call KernelPackage,random-omap))
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)