summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 9306601c7a..4a39663cdb 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -61,8 +61,11 @@ define PrepareStaging
endef
# preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
$(call PrepareStaging,$(STAGING_DIR))
+ mkdir -p $(STAGING_DIR)/host/share
+ rm -rf $(STAGING_DIR)/host/share/aclocal
+ ln -s $(STAGING_DIR_HOST)/share/aclocal $(STAGING_DIR)/host/share/
mkdir -p $(BUILD_DIR)/stamp
touch $@