summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile59
-rw-r--r--include/scan.mk43
2 files changed, 70 insertions, 32 deletions
diff --git a/Makefile b/Makefile
index fea8ed3162..d9db23678d 100644
--- a/Makefile
+++ b/Makefile
@@ -39,44 +39,37 @@ else
endif
export OPENWRTVERSION
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
- tmp/.pkginfo: FORCE
-endif
-
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
- tmp/.targetinfo: FORCE
-endif
-
ifeq ($(FORCE),)
.config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
world: tmp/.prereq-packages tmp/.prereq-target
endif
-ifeq ($(IS_TTY),1)
- define progress
- printf "\033[M\r$(1)" >&2;
- endef
-endif
-
-define dumpinfo
- @mkdir -p tmp
- @echo -n Collecting $(2) info...
- @-for dir in $(1)/*/; do \
- [ -f "$${dir}/Makefile" ] || continue; \
- $(call progress,Collecting $(2) info: $${dir%%/}) \
- echo Source-Makefile: $${dir}Makefile; \
- $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
- echo; \
- done > $@
- @($(call progress,Collecting $(2) info: done))
- @echo
+define stamp
+tmp/info/.stamp-$(1)-$(shell ls $(2)/*/Makefile | (md5sum || md5) 2>/dev/null | cut -d' ' -f1)
endef
-tmp/.pkginfo:
- $(call dumpinfo,package,package)
+STAMP_pkginfo=$(call stamp,pkginfo,package)
+STAMP_targetinfo=$(call stamp,targetinfo,target/linux)
+define scan_info
+
+$(STAMP_$(1)):
+ @mkdir -p tmp/info
+ @rm -f tmp/info/.stamp-$(1)*
+ @touch $$@
+
+$(foreach FILE,$(shell ls $(2)/*/Makefile),
+tmp/.$(1): $(FILE)
+$(FILE):
+)
+
+tmp/.$(1): $(STAMP_$(1))
+ @echo -n Collecting $(3) info...
+ @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$(1)" SCAN_DIR="$(2)" SCAN_NAME="$(3)" SCAN_DEPS="$(4)"
+
+endef
-tmp/.targetinfo:
- $(call dumpinfo,target/linux,target)
+$(eval $(call scan_info,pkginfo,package,package,include/package.mk))
+$(eval $(call scan_info,targetinfo,target/linux,target,include/kernel-build.mk include/kernel-version.mk))
tmpinfo-clean: FORCE
@-rm -rf tmp/.pkginfo tmp/.targetinfo
@@ -117,10 +110,12 @@ kernel_menuconfig: .config FORCE
-$(MAKE) target/linux-prepare
$(NO_TRACE_MAKE) -C target/linux menuconfig
-package/%: tmp/.pkginfo tmp/.targetinfo FORCE
+package/%:
+ @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
$(MAKE) -C package $(patsubst package/%,%,$@)
-target/%: tmp/.pkginfo tmp/.targetinfo FORCE
+target/%:
+ @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
$(MAKE) -C target $(patsubst target/%,%,$@)
tools/%: FORCE
diff --git a/include/scan.mk b/include/scan.mk
new file mode 100644
index 0000000000..7725fc713a
--- /dev/null
+++ b/include/scan.mk
@@ -0,0 +1,43 @@
+include $(TOPDIR)/include/verbose.mk
+
+SCAN_TARGET ?= pkginfo
+SCAN_NAME ?= package
+SCAN_DIR ?= package
+SCAN_DEPS ?= include/package.mk
+
+ifeq ($(IS_TTY),1)
+ define progress
+ printf "\033[M\r$(1)" >&2;
+ endef
+else
+ define progress
+ :
+ endef
+endif
+
+SCAN = $(patsubst $(SCAN_DIR)/%/Makefile,%,$(shell ls $(SCAN_DIR)/*/Makefile))
+tmp/.$(SCAN_TARGET):
+ @($(call progress,Collecting $(SCAN_NAME) info: merging...))
+ for file in $(SCAN); do \
+ cat tmp/info/.$(SCAN_TARGET)-$$file; \
+ done > $@
+ @($(call progress,Collecting $(SCAN_NAME) info: done))
+ @echo
+
+define scanfiles
+$(foreach FILE,$(SCAN),
+ tmp/.$(SCAN_TARGET): tmp/info/.$(SCAN_TARGET)-$(FILE) FORCE
+ tmp/info/.$(SCAN_TARGET)-$(FILE): $(SCAN_DEPS) $(SCAN_DIR)/$(FILE)/Makefile
+ { \
+ $$(call progress,Collecting $(SCAN_NAME) info: $(SCAN_DIR)/$(FILE)) \
+ echo Source-Makefile: $(SCAN_DIR)/$(FILE)/Makefile; \
+ $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $(SCAN_DIR)/$(FILE) 3>/dev/null || echo "ERROR: please fix $(SCAN_DIR)/$(FILE)/Makefile" >&2; \
+ echo; \
+ } > $$@
+)
+
+endef
+$(eval $(call scanfiles))
+
+FORCE:
+.PHONY: FORCE